Opened 9 years ago

Closed 9 years ago

#14768 closed defect (worksforme)

Notebook fails to display documentation of some lazy_imported modules

Reported by: Stefan Owned by: jason, mpatel, was, kini
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: notebook Keywords:
Cc: Merged in:
Authors: Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

To reproduce: in a notebook, type

lazy_import("sage.misc", "all", "bla")
bla? <tab>

I cannot reproduce it on the command line.

Attachments (1)

trac_14768_sage_getdef_exception.patch (701 bytes) - added by Stefan 9 years ago.
Add SyntaxError? to list of sage_getdef caught exceptions

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by Stefan

Add SyntaxError? to list of sage_getdef caught exceptions

comment:1 Changed 9 years ago by Volker Braun

Which version? and what do you mean by "fail"? I get (sage-5.11.beta1)

Definition: bla(alarm, ellipsis_range, ellipsis_iter, srange, xsrange, sxrange, getitem, cputime, verbose, set_verbose, set_verbose_files, get_verbose_files, unset_verbose_files, get_verbose, version, banner, add, union, uniq, powerset, subsets, exists, forall, is_iterator, random_sublist, mul, walltime, generic_cmp, repr_lincomb, pad_zeros, attrcall, SAGE_DB, SAGE_TMP, is_32_bit, is_64_bit, newton_method_sizes, compose, self_compose, nest)

which is odd but no traceback...

Last edited 9 years ago by Volker Braun (previous) (diff)

comment:2 Changed 9 years ago by Stefan

I'm working with 5.10.beta5.

Where do I even get 5.11.beta1? The Development Release on the homepage is 5.10.rc2...

comment:4 Changed 9 years ago by Stefan

I can confirm that the problem is gone in 5.11.beta1. The problem occurred with the "matroids" keyword from #7477, and that gives a normal documentation now.

Can I mark it as "duplicate/invalid/wontfix" or is that up to the release manager?

comment:5 Changed 9 years ago by Volker Braun

Keywords: lazy lazy_import documentation removed
Milestone: sage-5.11sage-duplicate/invalid/wontfix
Status: newneeds_review

You mark it as duplicate/invalid/wontfix and set status to needs_review

comment:6 Changed 9 years ago by Volker Braun

Reviewers: Volker Braun
Status: needs_reviewpositive_review

comment:7 Changed 9 years ago by Jeroen Demeyer

Resolution: worksforme
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.