Opened 8 years ago

Closed 8 years ago

#14757 closed defect (fixed)

Poset's show() method applied to an antichain gives bad picture

Reported by: darij Owned by: sage-combinat
Priority: major Milestone: sage-5.11
Component: combinatorics Keywords: combinat, poset, days49
Cc: sage-combinat, ncohen Merged in: sage-5.11.beta2
Authors: Darij Grinberg Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by tscrim)

sage: Poset({1: [], 2: [], 3: []}).show()

It shows all three elements as the same point. I suspect this hails from the plot method on Poset, since a digraph with no edges shows fine.

In the docstring of the plot method on Poset, there's also a typo: empy.

EDIT: This one can only be reproduced without dot2tex installed, since the methods branch depending on whether it is there or not.

Attachments (1)

trac_14757-acyclic_layout-ts.patch (800 bytes) - added by tscrim 8 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by darij

  • Description modified (diff)

comment:2 Changed 8 years ago by darij

  • Authors set to Travis Scrimshaw, Darij Grinberg
  • Description modified (diff)
  • Status changed from new to needs_review

comment:3 Changed 8 years ago by darij

  • Authors changed from Travis Scrimshaw, Darij Grinberg to Darij Grinberg
  • Cc ncohen added
  • Description modified (diff)
  • Keywords days49 added
  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_review to positive_review

comment:4 Changed 8 years ago by darij

Travis says he's reviewed the patch.

comment:5 Changed 8 years ago by tscrim

In case anyone is wondering, I did review this patch.

comment:6 Changed 8 years ago by jdemeyer

  • Status changed from positive_review to needs_work

Should be rebased, it doesn't apply to any version of Sage I tried.

Changed 8 years ago by tscrim

comment:7 Changed 8 years ago by tscrim

  • Description modified (diff)
  • Status changed from needs_work to needs_review

Hey Jeroen,

Try this version. I can't see why Darij's patch doesn't apply...

For patchbot:

Apply: trac_14757-acyclic_layout-ts.patch

comment:8 Changed 8 years ago by darij

Here is my queue on sage-5.10rc1:

darij@travis-virtualbox:~/sage-5.10.rc1/devel/sage-main$ hg qapplied
trac_8392-check_permutation-ts.patch
trac_14724-tableau_to_permutation_and_friend-cs.patch
trac_7983-major_index-dg.patch
trac_14748_deprecationwarning.patch
trac_14136-p_partition_enumerator_folded.patch
trac_14757-acyclic_layout-dg.patch

I don't see which of these should conflict with the patch...

comment:9 Changed 8 years ago by jdemeyer

  • Status changed from needs_review to positive_review

trac_14757-acyclic_layout-ts.patch works for me, I cannot explain why...

comment:10 Changed 8 years ago by darij

I think I know what caused the patch to fail. I had a weird wifi issue where my Windows host system would connect to the internet, while the Linux in the virtual machine wouldn't. So I took the patch from Linux and copypasted it into a text editor in Windows, from where I uploaded it. So it ended up in DOS format. Oops.

comment:11 Changed 8 years ago by jdemeyer

  • Merged in set to sage-5.11.beta2
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.