Opened 9 years ago

Closed 9 years ago

#14752 closed defect (fixed)

typo causes failure in nonsplit Cartan image for elliptic curve Galois representation

Reported by: John Cremona Owned by: John Cremona
Priority: minor Milestone: sage-5.11
Component: elliptic curves Keywords: galois representation
Cc: wuthrich Merged in: sage-5.11.rc0
Authors: John Cremona Reviewers: Chris Wuthrich
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by wuthrich)

In 5.10.rc2 (i.e. even after applying the patch at #14577) this happens:

EllipticCurve([0, 0, 0, -1129345880,-86028258620304]).galois_representation().image_type(11)
...
NameError: global name 'nonsplit_str' is not defined

Solution: fix typos ("nonsplit_str" --> "non_split_str") in two places.

Apply: The patch below.

Attachments (1)

trac14752-nonsplit.patch (1.7 KB) - added by John Cremona 9 years ago.
Applies to 5.10.rc2

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by John Cremona

Attachment: trac14752-nonsplit.patch added

Applies to 5.10.rc2

comment:1 Changed 9 years ago by John Cremona

The patch fixes the two typos and adds a doctest to show that the original case now works. In addition, I ran the following script:

for E in cremona_curves([11..300000]):
    D = E.discriminant()
    cm = E.has_cm()
    rho = E.galois_representation()
    lab = E.label()
    for p in primes_first_n(15):
        if not cm or not p.divides(D):
            print lab,p,rho.image_type(p)

with 5.10.rc2 + database_cremona_ellcurve-20121022.spkg and every curve in the database runs without crashing.

A future task is to check that the output agrees with that of Sutherland's independent C program.

comment:2 Changed 9 years ago by John Cremona

Authors: John Cremona
Cc: wuthrich added
Status: newneeds_review

comment:3 Changed 9 years ago by wuthrich

Description: modified (diff)
Reviewers: Chris Wuthrich
Status: needs_reviewpositive_review

All tests pass. Thanks for fixing my typos.

(To be precise, I get one error in sage/modular/modform/find_generators.py when testing with --long. But I am certain that it is not caused by this ticket.)

comment:4 Changed 9 years ago by Jeroen Demeyer

Merged in: sage-5.11.rc0
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.