Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#14700 closed enhancement (fixed)

Remove various unused files from the Sage library

Reported by: jdemeyer Owned by: tbd
Priority: minor Milestone: sage-5.11
Component: distribution Keywords:
Cc: leif Merged in: sage-5.11.beta1
Authors: Jeroen Demeyer Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

Tracked but unused:

  • sage/ext/pthread.pxi
  • sage/rings/solaris_fix.h
  • sage/gsl/gslonly.pxi
  • sage/gsl/stdio.pxi (empty file)
  • sage/libs/pari/to_gen.pxi (empty file)
  • sage/libs/singular/singular.pxi
  • sage/rings/real_double.pxi
  • sage/rings/padics/padic_generic_element.pxi
  • sage/rings/rational.pxi
  • sage/libs/mwrank/mwrank_embed.h
  • sage/modular/modsym/solaris_fix.h
  • sage/libs/linbox/matrix_rational_dense_linbox.cpp
  • sage/rings/notes/multi-polynomial_nonsense.txt (empty file)
  • sage/libs/pari/misc.pxi (empty file)
  • sage/combinat/root_system/type_None.py (empty file)
  • sage/misc/test_cpickle_sage.py (empty file)
  • sage/rings/noetherian_ring.py (empty apart from header)
  • sage/interfaces/magma_sim.py (almost no code, no doctests)
  • sage/schemes/hyperelliptic_curves/jacobian_constructor.py (almost no code, no doctests)
  • sage/structure/element_py.py (superseded by Cython file)
  • sage/structure/mutability_py.py (superseded by Cython file)
  • sage/gsl/README.txt
  • sage/interfaces/notes/mayr-groebner_examples.txt

Auto-generated but shipped:

  • sage/libs/pari/gen.h
  • sage/misc/allocator.h
  • sage/modular/arithgroup/farey_symbol.h
  • sage/rings/complex_double.h
  • sage/rings/integer.h
  • sage/rings/rational.h
  • sage/symbolic/pynac.h
  • sage/rings/complex_double_api.h
  • sage/rings/real_mpfi.h
  • sage/ext/interpreters/*.c
  • sage/ext/interpreters/*.h
  • sage/ext/interpreters/*.pyx
  • sage/ext/interpreters/*.pxd

Apply the following script to the Sage library:

hg rm \
    sage/ext/pthread.pxi \
    sage/rings/solaris_fix.h \
    sage/gsl/gslonly.pxi \
    sage/gsl/stdio.pxi \
    sage/libs/pari/to_gen.pxi \
    sage/libs/singular/singular.pxi \
    sage/rings/real_double.pxi \
    sage/rings/padics/padic_generic_element.pxi \
    sage/rings/rational.pxi \
    sage/libs/mwrank/mwrank_embed.h \
    sage/modular/modsym/solaris_fix.h \
    sage/libs/linbox/matrix_rational_dense_linbox.cpp \
    sage/rings/notes/multi-polynomial_nonsense.txt \
    sage/libs/pari/misc.pxi \
    sage/combinat/root_system/type_None.py \
    sage/misc/test_cpickle_sage.py \
    sage/rings/noetherian_ring.py \
    sage/interfaces/magma_sim.py \
    sage/schemes/hyperelliptic_curves/jacobian_constructor.py \
    sage/structure/element_py.py \
    sage/structure/mutability_py.py \
    sage/gsl/README.txt \
    sage/interfaces/notes/mayr-groebner_examples.txt
rm -v \
    sage/libs/pari/gen.h \
    sage/misc/allocator.h \
    sage/modular/arithgroup/farey_symbol.h \
    sage/rings/complex_double.h \
    sage/rings/integer.h \
    sage/rings/rational.h \
    sage/symbolic/pynac.h \
    sage/rings/complex_double_api.h \
    sage/rings/real_mpfi.h \
    sage/ext/interpreters/*.c \
    sage/ext/interpreters/*.h \
    sage/ext/interpreters/*.pyx \
    sage/ext/interpreters/*.pxd

hg commit -m "Trac #14700: remove unused files"

and apply 14700_rm_unused.patch

Attachments (1)

14700_rm_unused.patch (1.3 KB) - added by jdemeyer 7 years ago.

Download all attachments as: .zip

Change History (32)

comment:1 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:2 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:3 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:4 Changed 7 years ago by robertwb

  • Status changed from new to needs_review

comment:5 Changed 7 years ago by jdemeyer

  • Description modified (diff)
  • Status changed from needs_review to needs_work

comment:6 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:7 Changed 7 years ago by jdemeyer

  • Authors set to Jeroen Demeyer
  • Description modified (diff)

comment:8 Changed 7 years ago by jdemeyer

For upgrading, I would leave .hgignore alone.

comment:9 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:10 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:11 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:12 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:13 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:14 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:15 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:16 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:17 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:18 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:19 follow-up: Changed 7 years ago by leif

Where did the originally mentioned (untracked, unused but shipped, at some point generated) complex_double_api.h end up?

(Also, would you mind not updating the ticket's description every minute? ;-) )

comment:20 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:21 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:22 in reply to: ↑ 19 Changed 7 years ago by jdemeyer

Replying to leif:

Where did the originally mentioned (untracked, unused but shipped, at some point generated) complex_double_api.h end up?

I don't know why that got removed, it's back now.

Also, would you mind not updating the ticket's description every minute?

Well, it's not every minute :-) Anyway, I just kept finding more and more files.

I will now test to build from scratch with these files removed. If that works, I will set the ticket to needs_review.

comment:23 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:24 Changed 7 years ago by jdemeyer

Building without all these files worked, now doctesting...

Changed 7 years ago by jdemeyer

comment:25 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:26 Changed 7 years ago by jdemeyer

  • Status changed from needs_work to needs_review

comment:27 Changed 7 years ago by jdemeyer

I can confirm that Sage builds, doctests fine with this ticket applied and that the removed files don't appear in the sdist. So the review should be easy...

comment:28 Changed 7 years ago by vbraun

  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

Sounds good to me.

comment:29 Changed 7 years ago by jdemeyer

  • Merged in set to sage-5.11.beta1
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:30 Changed 7 years ago by jdemeyer

Due to #14721, four files came back:

sage/libs/pari/gen.h
sage/modular/arithgroup/farey_symbol.h
sage/rings/real_mpfi.h
sage/symbolic/pynac.h

comment:31 Changed 7 years ago by jdemeyer

Follow-up: #14739

Note: See TracTickets for help on using tickets.