Opened 9 years ago

Closed 9 years ago

#14606 closed defect (fixed)

Race condition with GAP workspaces

Reported by: jdemeyer Owned by: was
Priority: blocker Milestone: sage-5.10
Component: interfaces Keywords:
Cc: vbraun Merged in: sage-5.10.beta4
Authors: Jeroen Demeyer Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

sage -t --long devel/sage/sage/homology/examples.py
**********************************************************************
File "devel/sage/sage/homology/examples.py", line 106, in sage.homology.examples.facets_for_RP4
Failed example:
    A = facets_for_RP4()   # long time (1 or 2 seconds)
Exception raised:
    Traceback (most recent call last):
      File "/home/buildbot/build/sage/rosemary-1/rosemary_full/build/sage-5.10.beta4/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 466, in _run
        self.execute(example, compiled, test.globs)
      File "/home/buildbot/build/sage/rosemary-1/rosemary_full/build/sage-5.10.beta4/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 825, in execute
        exec compiled in globs
      File "<doctest sage.homology.examples.facets_for_RP4[1]>", line 1, in <module>
        A = facets_for_RP4()   # long time (1 or 2 seconds)
      File "/home/buildbot/build/sage/rosemary-1/rosemary_full/build/sage-5.10.beta4/local/lib/python2.7/site-packages/sage/homology/examples.py", line 120, in facets_for_RP4
        for g in G:
      File "/home/buildbot/build/sage/rosemary-1/rosemary_full/build/sage-5.10.beta4/local/lib/python2.7/site-packages/sage/groups/perm_gps/permgroup.py", line 777, in __iter__
        for g in self._gap_().Elements():
      File "sage_object.pyx", line 474, in sage.structure.sage_object.SageObject._gap_ (build/cythonized/sage/structure/sage_object.c:4682)
      File "sage_object.pyx", line 450, in sage.structure.sage_object.SageObject._interface_ (build/cythonized/sage/structure/sage_object.c:4274)
      File "/home/buildbot/build/sage/rosemary-1/rosemary_full/build/sage-5.10.beta4/local/lib/python2.7/site-packages/sage/interfaces/interface.py", line 199, in __call__
        return cls(self, x, name=name)
      File "/home/buildbot/build/sage/rosemary-1/rosemary_full/build/sage-5.10.beta4/local/lib/python2.7/site-packages/sage/interfaces/expect.py", line 1291, in __init__
        self._name = parent._create(value, name=name)
      File "/home/buildbot/build/sage/rosemary-1/rosemary_full/build/sage-5.10.beta4/local/lib/python2.7/site-packages/sage/interfaces/interface.py", line 389, in _create
        self.set(name, value)
      File "/home/buildbot/build/sage/rosemary-1/rosemary_full/build/sage-5.10.beta4/local/lib/python2.7/site-packages/sage/interfaces/gap.py", line 1314, in set
        out = self._eval_line(cmd, allow_use_file=True)
      File "/home/buildbot/build/sage/rosemary-1/rosemary_full/build/sage-5.10.beta4/local/lib/python2.7/site-packages/sage/interfaces/gap.py", line 730, in _eval_line
        self._start()
      File "/home/buildbot/build/sage/rosemary-1/rosemary_full/build/sage-5.10.beta4/local/lib/python2.7/site-packages/sage/interfaces/gap.py", line 1170, in _start
        gap_reset_workspace(verbose=False)
      File "/home/buildbot/build/sage/rosemary-1/rosemary_full/build/sage-5.10.beta4/local/lib/python2.7/site-packages/sage/interfaces/gap.py", line 1483, in gap_reset_workspace
        age = now - os.path.getatime(os.path.join(GAP_DIR, F))
      File "/home/buildbot/build/sage/rosemary-1/rosemary_full/build/sage-5.10.beta4/local/lib/python/genericpath.py", line 59, in getatime
        return os.stat(filename).st_atime
    OSError: [Errno 2] No such file or directory: '/home/buildbot/.sage/gap/workspace-4745535354938995875'
**********************************************************************

This is probably caused by two processes both deleting the same workspace.

Attachments (1)

14606_gap_race.patch (1.2 KB) - added by jdemeyer 9 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 9 years ago by jdemeyer

  • Authors set to Jeroen Demeyer
  • Description modified (diff)
  • Status changed from new to needs_review

Changed 9 years ago by jdemeyer

comment:2 Changed 9 years ago by vbraun

  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

Yes, looks like thats the culprit.

comment:3 Changed 9 years ago by jdemeyer

  • Merged in set to sage-5.10.beta4
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.