Opened 9 years ago

Last modified 9 years ago

#14556 closed enhancement

The maxima spkg has cruft dating back to days of clisp use — at Version 4

Reported by: Snark Owned by: jdemeyer
Priority: minor Milestone: sage-5.10
Component: packages: standard Keywords: noreadline
Cc: fbissey Merged in:
Authors: Julien Puydt Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by leif)

The maxima spkg creates a maxima-noreadline script, which is an old hack. This should go away.

Change History (6)

comment:1 in reply to: ↑ description Changed 9 years ago by jdemeyer

  • Description modified (diff)

Replying to Snark:

I might work on it myself, but first I must ask on which maxima spkg I should base my work on

http://boxen.math.washington.edu/home/release/sage-5.10.beta2/sage-5.10.beta2/spkg/standard/maxima-5.29.1.p1.spkg

comment:2 Changed 9 years ago by fbissey

  • Cc fbissey added

Changed 9 years ago by Snark

Patch to the sage library

comment:3 Changed 9 years ago by Snark

  • Status changed from new to needs_review

The two attached patches should fix this ticket.

comment:4 Changed 9 years ago by leif

  • Authors set to Julien Puydt
  • Description modified (diff)
  • Keywords noreadline added

You should also provide a "pre-patched" new spkg, with SPKG.txt updated as well.

Changed 9 years ago by Snark

Patch to the maxima spkg

Note: See TracTickets for help on using tickets.