Changes between Version 44 and Version 45 of Ticket #14405


Ignore:
Timestamp:
04/04/13 18:13:05 (8 years ago)
Author:
vbraun
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #14405 – Description

    v44 v45  
    44
    55The problem seems to be that the ancient libtermcap (no new releases since March 2002) is not enough anymore. I suggest to replace the termcap spkg with ncurses. Sage-5.9.beta3 builds fine. The only downside is that it takes ~2mb instead of ~300k, but on the upside the terminal is no longer broken.
     6
     7  * Apply [attachment:trac_14405_replace_termcap_with_ncurses.patch] to the SAGE_ROOT repo
     8  * Delete the termcap spkg
     9  * Add http://www.stp.dias.ie/~vbraun/Sage/spkg/ncurses-5.9.spkg
     10  * Update http://www.stp.dias.ie/~vbraun/Sage/spkg/readline-6.2.p4.spkg
     11