Opened 8 years ago

Closed 8 years ago

#14352 closed defect (duplicate)

Bug in parsing Maxima output with factorial

Reported by: eviatarbach Owned by: burcin
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: kcrisman Merged in:
Authors: Reviewers: Eviatar Bach, Karl-Dieter Crisman
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by eviatarbach)

Sage interprets the Maxima factorial operator as the inequality symbol in some cases:

sage: factorial(x) == 6                                                   
factorial(x) == 6
sage: _.simplify()
x != 6

I set the priority to critical because this can produce wrong answers. For example,

bool((factorial(x) == 6).simplify().subs(x=2))

Change History (6)

comment:1 Changed 8 years ago by eviatarbach

  • Description modified (diff)

comment:2 Changed 8 years ago by eviatarbach

Maxima uses # for inequality, so ! should never be interpreted as such.

comment:3 Changed 8 years ago by kcrisman

  • Cc kcrisman added
  • Milestone changed from sage-5.9 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

I think this is a duplicate of #11539. Do you agree?

comment:4 Changed 8 years ago by eviatarbach

Ah yes. I had even commented on that one, totally forgot about it...

comment:5 Changed 8 years ago by kcrisman

  • Reviewers set to Eviatar Bach, Karl-Dieter Crisman
  • Status changed from needs_review to positive_review

comment:6 Changed 8 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.