Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#14336 closed enhancement (fixed)

update M4RIE to version 20130416

Reported by: malb Owned by: tbd
Priority: major Milestone: sage-5.10
Component: packages: standard Keywords:
Cc: Merged in: sage-5.10.beta1
Authors: Martin Albrecht Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: #14335 Stopgaps:

Status badges

Description (last modified by vbraun)

M4RIE version 20130416 extends the supported finite field size to 216 (from 210). Furthermore, it can be built with 256MB of RAM.

Install http://boxen.math.washington.edu/home/malb/spkgs/libm4rie-20130416.spkg

Apply m4rie_new_version.patch

Attachments (1)

m4rie_new_version.patch (51.1 KB) - added by malb 8 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 8 years ago by malb

  • Description modified (diff)
  • Status changed from new to needs_review

comment:2 Changed 8 years ago by malb

  • Dependencies set to #14335

comment:3 Changed 8 years ago by Snark

It took two hours to compile it on my arm box, and the desktop interface was still running. Compared to the previous version which needed me to shut down X and kill as many services as possible, and where conversion.c took just by itself about six hours to compile, I think I can say this is a marked improvement!

Congrats!

comment:4 Changed 8 years ago by jdemeyer

Please don't make needless whitespace changes. Those will only lead to merge conflicts and makes it harder to review.

comment:5 Changed 8 years ago by malb

Yeah, sorry bout that. I'll not do it again.

comment:6 Changed 8 years ago by vbraun

  • Authors set to Martin Albrecht
  • Description modified (diff)

Can you take out the empty patch hunks (pure whitespace)?

comment:7 Changed 8 years ago by vbraun

Also, the patch doesn't apply to sage-5.9.beta5

comment:8 Changed 8 years ago by malb

I've rebased the patch and stripped whitespace only changes. The patch is still relatively large (50K) because the randomness source of random_matrix changed for some matrices (it's not driven by Givaro any more)

Changed 8 years ago by malb

comment:9 Changed 8 years ago by malb

Updated patch to fix a doctest failure which was caused by some whitespace change.

comment:10 Changed 8 years ago by vbraun

  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

Positive review

comment:11 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.9 to sage-5.10

comment:12 Changed 8 years ago by jdemeyer

  • Merged in set to sage-5.10.beta1
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:13 Changed 8 years ago by zimmerma

when I try to import the patch in Sage 5.9 (with hg_sage.import_patch("/tmp/m4rie_new_version.patch")), I get a diff -git output, then it enters my editor. It seems a commit log is missing in this patch.

Paul

comment:14 Changed 8 years ago by zimmerma

after adding a dummy commit log message, I get:

Cythonizing sage/matrix/matrix_double_dense.pyx
warning: sage/matrix/matrix_double_dense.pyx:1871:26: Unreachable code

Is it wanted?

Paul

comment:15 Changed 8 years ago by malb

Hi Paul, * strangely, enough the patch does have a commit message. Maybe the use of git style diffs is tripping things up?

  • the patch (doesn't seem to) touch matrix_double_dense.pyx.
Note: See TracTickets for help on using tickets.