Opened 8 years ago

Closed 8 years ago

#14315 closed defect (duplicate)

Matrices _matrix_() method is inconsistent with expected arguments

Reported by: tscrim Owned by: tscrim
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: linear algebra Keywords:
Cc: Merged in:
Authors: Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

sage: m = matrix({(0,0):4,(5,3):2})
sage: matrix(m) 
---------------------------------------------------------------------------
TypeError                                 Traceback (most recent call last)
<ipython-input-24-c5a0911a1542> in <module>()
----> 1 matrix(m)

/home/travis/sage-5.8.beta1/local/lib/python2.7/site-packages/sage/matrix/constructor.pyc in _matrix_constructor(*args, **kwds)
    526                 return args[0]._matrix_(sparse=sparse)
    527         except TypeError:
--> 528                 return args[0]._matrix_()
    529     elif len(args) == 2:
    530         if hasattr(args[0], '_matrix_'):

TypeError: _matrix_() takes exactly one argument (0 given)

In both sparse and dense integer matrices (I didn't check for other kinds), the expected input is 1 argument of a new ring for the entries.

Change History (3)

comment:1 Changed 8 years ago by tscrim

  • Milestone changed from sage-5.9 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Duplicate of #14314...

comment:2 Changed 8 years ago by tscrim

  • Authors Travis Scrimshaw deleted
  • Status changed from needs_review to positive_review

comment:3 Changed 8 years ago by jdemeyer

  • Resolution set to duplicate
  • Reviewers set to Travis Scrimshaw
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.