Opened 7 years ago

Closed 7 years ago

#14301 closed enhancement (fixed)

Improvement to alternating sign matrices

Reported by: tscrim Owned by: tscrim
Priority: major Milestone: sage-5.10
Component: combinatorics Keywords: ASM
Cc: sage-combinat, chrisjamesberg, stumpc5 Merged in: sage-5.10.beta2
Authors: Travis Scrimshaw Reviewers: Chris Berg
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: #14299, #14086 Stopgaps:

Description

Change (Alternating Sign Matrices) ASM's into category framework and implementation of various statistics and maps to combinatorial objects.

Attachments (1)

trac_14301-alt_sign_matrices-ts.patch (29.3 KB) - added by tscrim 7 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 7 years ago by tscrim

  • Dependencies set to #13299

Since monotone triangles are Gelfand-Tsetlin patterns, I'll be making use of some of the code in #14299.

Edit - wrong ticket.

Last edited 7 years ago by tscrim (previous) (diff)

comment:2 Changed 7 years ago by tscrim

  • Dependencies changed from #13299 to #14299

comment:3 Changed 7 years ago by tscrim

  • Cc stumpc5 added
  • Status changed from new to needs_review

comment:4 Changed 7 years ago by chrisjamesberg

  • Status changed from needs_review to positive_review

comment:5 Changed 7 years ago by jdemeyer

  • Milestone changed from sage-5.9 to sage-5.10

Please fill in your real name as reviewer.

comment:6 Changed 7 years ago by tscrim

  • Reviewers set to Chris Berg

comment:7 Changed 7 years ago by jdemeyer

  • Milestone changed from sage-5.10 to sage-pending

comment:8 Changed 7 years ago by jdemeyer

  • Milestone changed from sage-pending to sage-5.10

comment:9 Changed 7 years ago by jdemeyer

  • Status changed from positive_review to needs_work
----------------------------------------------------------------------
sage -t sage/combinat/alternating_sign_matrix.py  # 50 doctests failed
----------------------------------------------------------------------

comment:10 Changed 7 years ago by tscrim

  • Status changed from needs_work to needs_review

Fixed. Errors were caused by convention changes in #14299.

comment:11 Changed 7 years ago by chrisjamesberg

  • Status changed from needs_review to positive_review

comment:12 Changed 7 years ago by jdemeyer

  • Dependencies changed from #14299 to #14299, #14086
  • Status changed from positive_review to needs_work

This should be rebased to #14086.

Changed 7 years ago by tscrim

comment:13 Changed 7 years ago by tscrim

  • Status changed from needs_work to positive_review

Done.

comment:14 Changed 7 years ago by jdemeyer

  • Merged in set to sage-5.10.beta2
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.