Opened 9 years ago

Closed 7 years ago

#14280 closed defect (invalid)

The pexpect spkg looks strange

Reported by: Snark Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: interfaces Keywords:
Cc: Merged in:
Authors: Reviewers: Julien Puydt
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

First of all, it's stuck to 2.0 while upstream is up to something like 2.4 -- though it is explained in SPKG.txt that upgrading to 2.1 was out of the question because it was shockingly slow (sic). I don't know if it's the case and how to check it, so I would like to see that documented more properly.

Second, the spkg has the sources in two directories, src/ and src.del/, which contain mostly the same thing (there's a small diff).

Third, the spkg comes with patches, and those patches do not say whether they have been forwarded upstream, which as far as I know means they didn't.

Change History (8)

comment:1 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:2 Changed 8 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:3 Changed 8 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:4 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:5 Changed 7 years ago by leif

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_info

I guess this no longer applies.

comment:6 Changed 7 years ago by Snark

  • Status changed from needs_info to positive_review

Yes, please just close!

comment:7 Changed 7 years ago by leif

  • Reviewers set to Julien Puydt

comment:8 Changed 7 years ago by vbraun

  • Resolution set to invalid
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.