Opened 7 years ago

Closed 7 years ago

#14245 closed defect (fixed)

Cloning doesn't properly copy the _static doc directory

Reported by: hivert Owned by: mvngu
Priority: blocker Milestone: sage-5.8
Component: documentation Keywords: _static clone
Cc: jhpalmieri, leif, niles, hivert, mguaypaq, mhansen Merged in: sage-5.8.rc0
Authors: John Palmieri Reviewers: Florent Hivert
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by hivert)

When cloning Sage (eg: for combinat), the doc is copied but not properly: Before the clone in doc/output/html/en/reference/numerical there is a symlink _static to ../_static. After the clone, it is an empty directory. Also the directories such as

doc/en/reference/algebras/sage
doc/en/reference/calculus/sage
...

are note copied at all.

Attachments (1)

trac_14245_clone.patch (2.0 KB) - added by jhpalmieri 7 years ago.
scripts repo

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by hivert

  • Type changed from enhancement to defect

comment:2 Changed 7 years ago by kcrisman

  • Description modified (diff)
  • Priority changed from critical to blocker

comment:3 Changed 7 years ago by jhpalmieri

  • Authors set to John Palmieri
  • Keywords clone added
  • Status changed from new to needs_review

I think this patch will fix the problem. I also think that the sage-clone script could use some attention in general, but now is not the time.

comment:4 Changed 7 years ago by hivert

I'm testing this patch currently but I think I'll give it positive review.

Florent

comment:5 Changed 7 years ago by hivert

Hum ! The problem of copying the _static directory is fixed but there is another one: There is a lot of

WARNING: toctree contains reference to nonexisting document '...'

and indeed the doc is empty. This should also be fixed. I'm investigating for the cause.

comment:6 Changed 7 years ago by hivert

Ok ! I think I got it. During cloning the directories such as

doc/en/reference/algebras/sage
doc/en/reference/calculus/sage
...

are note copied. Sorry I have to go to bed... I'll fix this tomorrow if no one beats me.

comment:7 Changed 7 years ago by jhpalmieri

Sorry, I missed that. Here's a better attempt.

Changed 7 years ago by jhpalmieri

scripts repo

comment:8 Changed 7 years ago by hivert

  • Description modified (diff)
  • Reviewers set to Florent Hivert
  • Status changed from needs_review to positive_review

Looks good to me. Thanks !

comment:9 follow-up: Changed 7 years ago by jhpalmieri

I wonder if we should (on another ticket, like #13245) also disable docbuilding altogether when cloning...

comment:10 in reply to: ↑ 9 Changed 7 years ago by leif

Replying to jhpalmieri:

I wonder if we should (on another ticket, like #13245) also disable docbuilding altogether when cloning...

+N

comment:11 Changed 7 years ago by jdemeyer

  • Milestone changed from sage-5.9 to sage-5.8

comment:12 Changed 7 years ago by jdemeyer

  • Merged in set to sage-5.8.rc0
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.