Opened 8 years ago

Closed 8 months ago

#14133 closed defect (invalid)

No output from cell after error was expanded

Reported by: ManDay Owned by: jason, mpatel, was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: notebook Keywords: error notebook invisible latex typeset
Cc: chapoton Merged in:
Authors: Reviewers:
Report Upstream: Reported upstream. No feedback yet. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Reproducible (and originally noticed) on the online "alpha" server.

Under the following conditions a cell will not produce any readable ouput in the notebook. However, output produced by html( ) will still appear - but anything typesetted (including tokens inside the html( ) such as

html( "This will still be visible - $But this wont$" )

will no longer be visible and the only solution is to delete the cell alltogether:

Typeset is ON There occurred an Error The error was "expanded" into details by clicking left of it The error was fixed

Reproduce like that: Enable Typeset. In a cell, type

k+; 5

Press Shift-Enter - an Error will appear. Expand the error by clicking left of it. Delete the "k+;" line, press Shift-Enter again - no output will appear.

Change History (10)

comment:1 Changed 8 years ago by kcrisman

Can you try this on a more recent server to see if the instructions still would work to do this? The server was updated quite a bit since alpha, which is (perhaps ironically) no longer anywhere near cutting edge. Unfortunately, sagenb.org is also only at Sage 5.4, though we should be at 5.6 and 5.7 is nearly released...

comment:2 Changed 8 years ago by ManDay

I'd try it on the Online server (alpha) right away, if someone manages to update that to... alpha... 5.6 that is ;)

comment:3 Changed 8 years ago by ppurka

Strictly speaking, this is not an error. The output of a cell has three levels of output - let's call them default, verbose and hidden. The first level is the default. When there is no typeset output, the whole output is present in the default and in the verbose level. The output in the verbose level is what you get when you click on the left to show extra output when some error happens. If you click it once more you will cycle back to the hidden level. So, essentially it is cycle like this:

default -> [click] -> verbose -> [click] -> hidden -> [click] -> default

When the output is typeset, the whole output is present in only the first level - this might be a bug, since I think the second level is for the verbose output and it should include whatever is in the default first level.

So, if we follow your steps to reproduce this "bug", we will do this

  1. Turn on Typeset.
  2. Type k+; 5 in a cell and evaluate
  3. Click on left of the output to show verbose output
  4. Remove k+; and evaluate
  5. There is no output since we are in the verbose level and for some reason the verbose output is empty when Typeset is on, so we will click to the left of what should have been the output, but we click twice.
  6. We will see the typeset 5 in the output.
Last edited 8 years ago by ppurka (previous) (diff)

comment:4 Changed 8 years ago by ppurka

  • Report Upstream changed from N/A to Reported upstream. No feedback yet.

comment:5 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:6 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:7 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:8 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:9 Changed 9 months ago by mkoeppe

  • Cc chapoton added
  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Proposing to close all sagenb tickets as outdated, so that all remaining open tickets in the notebook component are about the Jupyter notebook.

comment:10 Changed 8 months ago by chapoton

  • Resolution set to invalid
  • Status changed from needs_review to closed
Note: See TracTickets for help on using tickets.