Opened 7 years ago

Closed 7 years ago

#14080 closed enhancement (fixed)

Simplify cdefs.pxi using Cython's libc module

Reported by: jdemeyer Owned by: jason
Priority: major Milestone: sage-5.8
Component: misc Keywords:
Cc: robertwb Merged in: sage-5.8.beta0
Authors: Jeroen Demeyer Reviewers: David Roe
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description


Attachments (1)

14080_cdefs.patch (8.5 KB) - added by jdemeyer 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by jdemeyer

comment:1 Changed 7 years ago by jdemeyer

  • Authors set to Jeroen Demeyer
  • Cc robertwb added
  • Status changed from new to needs_review

comment:2 Changed 7 years ago by roed

  • Status changed from needs_review to needs_info

There are test failures here. Any idea what's causing them?

comment:3 Changed 7 years ago by jdemeyer

  • Status changed from needs_info to needs_review

I have no idea, I cannot reproduce it. Perhaps a bug in the patchbot client?

comment:4 Changed 7 years ago by roed

From looking at the actual failures, that seemed likely. I'll try it on my machine.

comment:5 Changed 7 years ago by roed

  • Reviewers set to David Roe
  • Status changed from needs_review to positive_review

Works for me. Since I don't see why the changes here would cause such failures, I'll go with the "bug in the patchbot client" explanation.

comment:6 Changed 7 years ago by jdemeyer

  • Milestone changed from sage-5.7 to sage-5.8

comment:7 Changed 7 years ago by jdemeyer

  • Merged in set to sage-5.8.beta0
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.