Opened 9 years ago

Closed 8 years ago

Last modified 6 years ago

#14077 closed defect (duplicate)

Doctest failures on ARM Chromebook

Reported by: Bouillaguet Owned by: jason, jkantor
Priority: major Milestone: sage-6.2
Component: numerical Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by chapoton)

uname -a
Linux localhost.localdomain 3.4.0 #1 SMP Tue Dec 11 03:10:30 PST 2012 armv7l armv7l armv7l GNU/Linux
cat /proc/cpuinfo
Processor: ARMv7 Processor rev 4 (v7l)
processor: 0
BogoMIPS: 1694.10

processor: 1
BogoMIPS: 1694.10

Features: swp half thumb fastmult vfp edsp thumbee neon vfpv3 tls vfpv4 idiva idivt 
CPU implementer: 0x41
CPU architecture: 7
CPU variant: 0x0
CPU part: 0xc0f
CPU revision: 4

Hardware: SAMSUNG EXYNOS5 (Flattened Device Tree)
Revision: 0000
Serial: 0000000000000000
make ptestlong
...
The following tests failed:

sage -t  --long -force_lib devel/sage/sage/rings/arith.py # 1 doctests failed
sage -t  --long -force_lib devel/sage/sage/symbolic/expression.pyx # 1 doctests failed
sage -t  --long -force_lib devel/sage/sage/functions/other.py # 1 doctests failed
----------------------------------------------------------------------
Total time for all tests: 11437.2 seconds

The detailed failures are:

**********************************************************************
File "/home/user/Downloads/sage-5.6/devel/sage/sage/rings/arith.py", line 3162:
    sage: binomial(0.5r, 5)
Expected:
    0.02734375
Got:
    0.02734375000000001
**********************************************************************
**********************************************************************
File "/home/user/Downloads/sage-5.6/devel/sage/sage/symbolic/expression.pyx", line 6698:
    sage: SR(10.0r).gamma()
Expected:
    362880.0
Got:
    362880.00000000047
#0: simplify_sum(expr='sum(q^k,k,0,inf))
#1: simplify_sum(expr=a*'sum(q^k,k,0,inf))
**********************************************************************

and:

**********************************************************************
File "/home/user/Downloads/sage-5.6/devel/sage/sage/functions/other.py", line 664:
    sage: gamma1(float(6))
Expected:
    120.0
Got:
    119.99999999999997
**********************************************************************

Change History (9)

comment:1 Changed 9 years ago by jdemeyer

Isn't this essentially a duplicate of #10285?

comment:3 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:4 Changed 8 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:5 Changed 8 years ago by dimpase

  • Status changed from new to needs_review

I propose this be closed as a duplicate.

comment:6 Changed 8 years ago by dimpase

  • Status changed from needs_review to positive_review

comment:7 Changed 8 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed

comment:8 Changed 8 years ago by vbraun

  • Reviewers set to Jeroen Demeyer

comment:9 Changed 6 years ago by chapoton

  • Description modified (diff)
Note: See TracTickets for help on using tickets.