Opened 8 years ago

Closed 7 years ago

#13978 closed defect (duplicate)

Static 3d plots are not working with a separate account for worker

Reported by: novoselt Owned by: jason, mpatel, was
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: notebook Keywords:
Cc: jason, gutow Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

As reported before static 3D plots are horrible if Sage Notebook is running with separate accounts for server and worker. If the ulimits for the worker are too tight (meaning < 5 GB!!! virtual memory), Tachyon is used to draw the static plot instead of jmol. Since sizes of lines/arrows and transparency are interpreted differently, the result is truly horrible. With enough memory available, the plots seem to be done by jmol, but there is permission issue preventing anything being shown apart from error messages.

Change History (7)

comment:1 Changed 8 years ago by novoselt

  • Type changed from PLEASE CHANGE to defect

comment:2 Changed 8 years ago by gutow

This is very odd. The server side JmolData?.jar is launched with a request for a maximum of 512 MB of memory. It won't use even that much if it doesn't need it. I'm also not clear on why the system would default to Tachyon when memory is tight. The decision is made dependent upon the availability of a JavaVM of the proper version, not on memory constraints. The code simply runs "java --version". If it does not get a proper version back it defaults to Tachyon. The errors quoted in the previous discussion, suggest that something else is using gobs of memory before any attempt is made to launch a JVM. There is nothing we can do about that. All the other things Sage uses will have to be less demanding on memory. My guess is that Maxima and maybe GAP are gobbling up memory.

As to the permission issues, are they related to the static plots or the new constraints that many browsers are putting on Java applets? I'm trying to catch up with that, but only FireFox? seems to be behaving reasonably anymore. Reading back through our previous linked discussion mentioned above, I think this relates to the permissions available to the workers. I think all workers need to be in the same group as the main user and all members of the group must have rw permissions. This may be an issue for the notebook in general. I'm not familiar with the code that creates worksheet folders. Is there work being done that this issue can be piggybacked on?

comment:3 Changed 8 years ago by novoselt

"java -version" does not work for me unless I increase virtual memory limit above 4Gb.

The permission issue is with references to files which are stored in server directories closed to everybody except for the server. Trying to manually set group access bits does not help - they are reset on cell reexecution. I don't think there is anything wrong with jmol here and memory issue, while annoying, can be lived with. But permission errors don't go away even after using Jason's patch to make plots interactive by default (I see the plots and they are interactive, but somewhere there is still access to restricted files generating errors). I do not think it is related to browser security.

comment:4 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:5 Changed 7 years ago by jdemeyer

  • Milestone changed from sage-5.13 to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Duplicate of #14358

comment:6 Changed 7 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:7 Changed 7 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.