Opened 7 years ago

Closed 7 years ago

#13976 closed defect (fixed)

Problem in the return type of BooleanIdeal.variety()

Reported by: Bouillaguet Owned by: malb
Priority: major Milestone: sage-5.7
Component: commutative algebra Keywords:
Cc: malb, AlexanderDreyer Merged in: sage-5.7.beta1
Authors: Charles Bouillaguet Reviewers: Martin Albrecht
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

One can do:

sage= R.<x,y,z> = GF(2)[]
sage: I = ideal( [ x*y*z + x*z + y + 1, x+y+z+1] )
sage: sols = (I+sage.rings.ideal.FieldIdeal(R)).variety()
sage: sols
[{y: 1, z: 0, x: 0}, {y: 1, z: 1, x: 1}]

sage: sols[0][y]
1

Now the same thing fails in BooleanRing's:

sage: R.<x,y,z> = BooleanPolynomialRing()
sage: I = ideal( [ x*y*z + x*z + y + 1, x+y+z+1] )
sage: sols = I.variety()
sage: sols
[{y: 1, z: 0, x: 0}, {y: 1, z: 1, x: 1}]

sage: sols[0][y]
Traceback (most recent call last):
...
KeyError: y

This is caused by an ugly hack (I authored...) in #13103 to make the variety() function work on BooleanIdeal's.

Attachments (1)

13976_variety_again.patch (4.3 KB) - added by Bouillaguet 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by Bouillaguet

comment:1 Changed 7 years ago by Bouillaguet

  • Authors set to Charles Bouillaguet
  • Status changed from new to needs_review

comment:2 Changed 7 years ago by malb

  • Reviewers set to Martin Albrecht
  • Status changed from needs_review to positive_review

Looks okay.

comment:3 Changed 7 years ago by AlexanderDreyer

Nice patch, and Thank you for your great supporting work, Charles!

comment:4 Changed 7 years ago by jdemeyer

  • Merged in set to sage-5.7.beta1
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.