Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#13938 closed defect (fixed)

Don't set CCACHE_DIR

Reported by: Jeroen Demeyer Owned by: Georg S. Weber
Priority: blocker Milestone: sage-5.6
Component: build Keywords:
Cc: Punarbasu Purkayastha Merged in: sage-5.6.rc0
Authors: Jeroen Demeyer Reviewers: R. Andrew Ohana, Punarbasu Purkayastha
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by Jeroen Demeyer)

This is a follow-up to #13032. After consulting sage-devel, it seems like a bad idea to set CCACHE_DIR unconditionally, so let's not do this.

Blocker because #13032 is a regression for people using a system-wide ccache installation.

optional spkg: http://boxen.math.washington.edu/home/jdemeyer/spkg/ccache-3.1.9.spkg

apply: 13938_ccache_default_dir.patch to the SAGE_ROOT repository.

Attachments (2)

13938_ccache_default_dir.patch (903 bytes) - added by Jeroen Demeyer 10 years ago.
ccache-3.1.9.diff (2.9 KB) - added by Jeroen Demeyer 10 years ago.
Diff for the ccache spkg, for review only

Download all attachments as: .zip

Change History (14)

Changed 10 years ago by Jeroen Demeyer

comment:1 Changed 10 years ago by Jeroen Demeyer

Description: modified (diff)

comment:2 Changed 10 years ago by Jeroen Demeyer

Description: modified (diff)

comment:3 Changed 10 years ago by Jeroen Demeyer

Description: modified (diff)

comment:4 Changed 10 years ago by Jeroen Demeyer

Status: newneeds_review

comment:5 Changed 10 years ago by Jeroen Demeyer

Description: modified (diff)

Changed 10 years ago by Jeroen Demeyer

Attachment: ccache-3.1.9.diff added

Diff for the ccache spkg, for review only

comment:6 Changed 10 years ago by R. Andrew Ohana

Status: needs_reviewneeds_info

This appears to implement (1) from the sage-devel discussion, but to me it seemed like (3) was more the consensus from that thread. If (1) is the consensus, then this looks fine to me.

comment:7 Changed 10 years ago by Jeroen Demeyer

Yes, this implements (1). After looking at the thread again, I'd say that (1) was the consensus.

comment:8 Changed 10 years ago by Punarbasu Purkayastha

This looks good to me. I installed the spkg and the patch, and got no surprises. Tried out some small package like cliquer and it finished within 2 sec, cython took 22sec.

@ohanar: since you are the main author of the ccache ticket, I will wait for your input - if you have no objection, then set it to positive review.

comment:9 Changed 10 years ago by R. Andrew Ohana

Status: needs_infoneeds_review

no objection

comment:10 Changed 10 years ago by R. Andrew Ohana

Reviewers: R. Andrew Ohana, Punarbasu Purkayastha
Status: needs_reviewpositive_review

comment:11 Changed 10 years ago by Jeroen Demeyer

Merged in: sage-5.6.rc0
Resolution: fixed
Status: positive_reviewclosed

comment:12 Changed 10 years ago by Harald Schilly

spkg is on the servers!

Note: See TracTickets for help on using tickets.