Opened 8 years ago

Last modified 7 years ago

#13905 new defect

Dollar signs in documentation

Reported by: novoselt Owned by: mvngu
Priority: major Milestone: sage-6.4
Component: documentation Keywords:
Cc: jhpalmieri Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

It is allowed to use dollar signs in the documentation to denote math stuff. It is also supposed to be possible to escape them like \$ to get plain dollars. When I put, say, "There are \$10 and \$5 bills." in a module docstring and build documentation, the text between dollars is in math mode. The same seems to happen with introspection. The source code does show $'s without anything, but it seems that they get caught by MathJax during rendering.

This should not happen: either MathJax should leave $'s alone, or they have to be escaped somehow again (automatically, so that \$ works in the source file).

Sage version: 5.6.beta1.

Change History (5)

comment:1 Changed 8 years ago by novoselt

Hi John,

Could you take a look at it? I think I finally understood what's going on after a few hours, but I don't know how to proceed about fixing it.

Thank you! Andrey

comment:2 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:3 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:4 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:5 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4
Note: See TracTickets for help on using tickets.