Opened 7 years ago

Closed 6 years ago

#13837 closed defect (fixed)

trivial typo in modular/modsym/ambient.py (in modular symbols)

Reported by: was Owned by: davidloeffler
Priority: trivial Milestone: sage-5.11
Component: modular forms Keywords: beginner sd51
Cc: Merged in: sage-5.11.rc0
Authors: André Apitzsch Reviewers: David Loeffler
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

I noticed:

        Uses Heilbronn-Cremonma matrices of `p` is prime, else use
        Heilbronn-Merel matrices.

It should be "if p is prime" not "of p is prime".

Attachments (1)

trac_13837.2.patch (10.8 KB) - added by davidloeffler 6 years ago.
copy with non-ASCII characters removed

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by aapitzsch

  • Authors set to André Apitzsch
  • Status changed from new to needs_review

The attached patch also replaces some deprecated python syntax.

comment:2 follow-up: Changed 7 years ago by davidloeffler

We should probably also correct the other typo in that sentence ("Cremonma"). The patchbot seems unhappy, but I can't believe that the failure has anything to do with your patch!

comment:3 in reply to: ↑ 2 Changed 7 years ago by aapitzsch

Replying to davidloeffler:

We should probably also correct the other typo in that sentence ("Cremonma").

Done.

comment:4 Changed 7 years ago by jdemeyer

  • Status changed from needs_review to needs_work

I cannot apply your patch:

$ hg qimport -P http://trac.sagemath.org/sage_trac/raw-attachment/ticket/13837/trac_13837.patch
adding trac_13837.patch to series file
applying trac_13837.patch
transaction abort!
rollback completed
cleaning up working directory...done
abort: decoding near 'André Apitzsc': 'ascii' codec can't decode byte 0xc3 in position 4: ordinal not in range(128)!

comment:5 Changed 7 years ago by aapitzsch

I cannot reproduce this. With mercurial on Archlinux I get

$ hg qimport -P http://trac.sagemath.org/sage_trac/raw-attachment/ticket/13837/trac_13837.patch
Füge trac_13837.patch zur Seriendatei hinzu
Wende trac_13837.patch an
jetzt bei: trac_13837.patch

Why hasn't this happened with other patches of mine, for example that one attached to #13815? Any suggestions how to fix this?

Changed 6 years ago by davidloeffler

copy with non-ASCII characters removed

comment:6 Changed 6 years ago by davidloeffler

  • Status changed from needs_work to positive_review

I have brutally removed the accent from Andre's name and uploaded a new patch. Sorry, Andre, but I thought you'd prefer this to your patch sitting in limbo any longer.

comment:7 Changed 6 years ago by mstreng

  • Keywords sd51 added

comment:8 Changed 6 years ago by jdemeyer

  • Reviewers set to David Loeffler

comment:9 Changed 6 years ago by jdemeyer

  • Merged in set to sage-5.11.rc0
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.