Opened 8 years ago

Last modified 7 years ago

#13818 new enhancement

The rescale_col method of matrices should be rescale_column

Reported by: Snark Owned by: jason, was
Priority: minor Milestone: sage-6.4
Component: linear algebra Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The other pairs of methods (swap_rows/swap_columns, add_multiple_of_row/add_multiple_of_column, row_space/column_space, etc) all use the unabbreviated nouns, so I suggest renaming rescale_col to rescale_column for coherence.

I would provide a brutal patch (sed-magic), but it would certainly be worthy to add a rescale_col method which calls rescale_column and warns about the renaming before pulling the plug on the old method name -- and I don't know how to do that.

Change History (4)

comment:1 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:2 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:3 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:4 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4
Note: See TracTickets for help on using tickets.