Opened 10 years ago

Closed 10 years ago

#13804 closed defect (fixed)

libfplll fails to build in parallel on Cygwin

Reported by: Jean-Pierre Flori Owned by: tbd
Priority: major Milestone: sage-5.6
Component: porting: Cygwin Keywords: libfplll spkg cygwin
Cc: Karl-Dieter Crisman, Dima Pasechnik Merged in: sage-5.6.rc0
Authors: Jean-Pierre Flori Reviewers: Karl-Dieter Crisman
Report Upstream: None of the above - read trac for reasoning. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by Jean-Pierre Flori)

On my installation of Cywgin (on 64 bits Windows 7), building libfplll fails because make complains there is no rule to build fplll if I use MAKE=make -j4". Indeed there is one for fplll$(EXEEXT), but no for fplll and $(EXEEXT) is non empty on Cygwin. Nonetheless, if the file fplll.exe exists, then "make fplll" will happily tell you that its up to date and go on with its job.

This does not happen with a sequential build.

Use the spkg at http://boxen.math.washington.edu/home/jpflori/libfplll-3.0.12.p3.spkg

And by the way the libfplll we ship is old and the problem is not present in the most recent version. See #12835. So I won't report this upstream.

Attachments (1)

libfplll-3.0.12.p3.diff (22.3 KB) - added by Jean-Pierre Flori 10 years ago.
Spkg diff, for review only.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by Jean-Pierre Flori

Or maybe Cywgin make used to automagically translate targets to add .exe extension and does not anymore.

comment:2 Changed 10 years ago by Jean-Pierre Flori

Description: modified (diff)
Summary: libfplll fails to build on recent Cygwinlibfplll fails to build in parallel on Cygwin

Groumpf, I got it to install by not using a parallel build.

comment:3 Changed 10 years ago by Karl-Dieter Crisman

Component: PLEASE CHANGEcygwin
Type: PLEASE CHANGEdefect

Yeah, I've never seen this because my machine is certainly always with one thread. I guess I never even thought to try it in parallel, but as it's XP I'm sure that wouldn't be very useful in any case.

Changed 10 years ago by Jean-Pierre Flori

Attachment: libfplll-3.0.12.p3.diff added

Spkg diff, for review only.

comment:4 Changed 10 years ago by Jean-Pierre Flori

Authors: Jean-Pierre Flori
Description: modified (diff)
Status: newneeds_review

comment:5 Changed 10 years ago by Karl-Dieter Crisman

Brief look at diff seems okay, and this installed fine on XP with passed (self, SAGE_CHECK=yes) tests. I obviously can't check whether this actually works in terms of multiple threads, though this is the right command to disable parallel make, and is only on Cygwin, so we should probably let it go through.

Last edited 10 years ago by Karl-Dieter Crisman (previous) (diff)

comment:6 Changed 10 years ago by Karl-Dieter Crisman

Reviewers: Karl-Dieter Crisman
Status: needs_reviewpositive_review

Same result on Mac and sage.math, and after ./sage -b passes the sage/libs/fplll tests as well. Let's get this in.

comment:7 Changed 10 years ago by Jeroen Demeyer

Merged in: sage-5.6.rc0
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.