Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#13802 closed defect (fixed)

Extra includes needed for letterplace for Cygwin on XP — at Version 9

Reported by: kcrisman Owned by: tbd
Priority: major Milestone: sage-5.6
Component: porting: Cygwin Keywords:
Cc: jpflori, AlexanderDreyer Merged in: sage-5.6.beta0
Authors: Karl-Dieter Crisman Reviewers: Alexander Dreyer
Report Upstream: None of the above - read trac for reasoning. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

Executing 327 commands (using 1 thread) 
gcc -I/usr/include/ncurses -fno-strict-aliasing -fwrapv -DNDEBUG -g - 
fwrapv -O3 -Wall -Wstrict-prototypes -I/home/newsagetest/sage-5.5.rc0/ 
local/include/singular/ -I/home/newsagetest/sage-5.5.rc0/local/include 
-I/home/newsagetest/sage-5.5.rc0/local/include/csage -I/home/ 
newsagetest/sage-5.5.rc0/devel/sage/sage/ext -I/home/newsagetest/ 
sage-5.5.rc0/local/include/python2.7 -c sage/algebras/letterplace/ 
free_algebra_letterplace.cpp -o build/temp.cygwin-1.7.9-i686-2.7/sage/ 
algebras/letterplace/free_algebra_letterplace.o -w 
cc1plus: warning: command line option "-Wstrict-prototypes" is valid 
for Ada/C/ObjC but not for C++ 
g++ -shared -Wl,--enable-auto-image-base -L/home/newsagetest/ 
sage-5.5.rc0/local/lib build/temp.cygwin-1.7.9-i686-2.7/sage/algebras/ 
letterplace/free_algebra_letterplace.o -L/home/newsagetest/ 
sage-5.5.rc0/local/lib -L/home/newsagetest/sage-5.5.rc0/local/lib/ 
python2.7/config -lcsage -lstdc++ -lntl -lpython2.7 -o build/ 
lib.cygwin-1.7.9-i686-2.7/sage/algebras/letterplace/ 
free_algebra_letterplace.dll 
build/temp.cygwin-1.7.9-i686-2.7/sage/algebras/letterplace/ 
free_algebra_letterplace.o: In function 
`__static_initialization_and_destruction_0': 
/home/newsagetest/sage-5.5.rc0/local/include/factory/factory.h:199: 
undefined reference to `initCanonicalForm()' 
collect2: ld returned 1 exit status 
error: command 'g++' failed with exit status 1 
gcc -I/usr/include/ncurses -fno-strict-aliasing -fwrapv -DNDEBUG -g - 
fwrapv -O3 -Wall -Wstrict-prototypes -I/home/newsagetest/sage-5.5.rc0/ 
local/include/singular/ -I/home/newsagetest/sage-5.5.rc0/local/include 
-I/home/newsagetest/sage-5.5.rc0/local/include/csage -I/home/ 
newsagetest/sage-5.5.rc0/devel/sage/sage/ext -I/home/newsagetest/ 
sage-5.5.rc0/local/include/python2.7 -c sage/algebras/letterplace/ 
free_algebra_element_letterplace.cpp -o build/temp.cygwin-1.7.9- 
i686-2.7/sage/algebras/letterplace/free_algebra_element_letterplace.o - 
w 
Error installing modified sage library code. 

Apply trac_13802-cygwin.patch.

Change History (10)

comment:1 Changed 6 years ago by kcrisman

Presumably the fix is to add SAGE_INC + 'factory' to module_list.py, maybe also the libraries. Sloppy work at #7797, perhaps?

comment:2 Changed 6 years ago by kcrisman

Okay, I added that and the singular_libs, and it seems to be working.

Changed 6 years ago by kcrisman

Apply to Sage library

comment:3 Changed 6 years ago by kcrisman

  • Authors set to Karl-Dieter Crisman
  • Description modified (diff)
  • Status changed from new to needs_review

Apply trac_13802-cygwin.patch

I don't know how to have anyone review this beyond someone with Cygwin on XP. Maybe someone from #7797 can at least verify it's not bad?

comment:4 Changed 6 years ago by kcrisman

This does work on Mac 10.7 and sage.math, so hopefully someone can independently confirm that and check that the patch makes sense.

comment:5 Changed 6 years ago by AlexanderDreyer

  • Cc AlexanderDreyer added
  • Report Upstream changed from N/A to None of the above - read trac for reasoning.
  • Reviewers set to Alexander Dreyer
  • Status changed from needs_review to positive_review

I can confirm, that the patch makes sense, it is consistent with the other Singular-based modules, and it does not harm anything on other platforms.

So positive review!

comment:6 Changed 6 years ago by kcrisman

Thanks!

comment:7 Changed 6 years ago by jpflori

I can confirm this is also needed and working on 64 bits Windows 7.

comment:8 Changed 6 years ago by jdemeyer

  • Merged in set to sage-5.6.beta0
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:9 Changed 6 years ago by jdemeyer

  • Description modified (diff)
Note: See TracTickets for help on using tickets.