Opened 9 years ago

Closed 7 years ago

#13604 closed defect (fixed)

.DS_Store garbage in sympy spkg

Reported by: pdehaye Owned by: tbd
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords: .DS_Store
Cc: certik Merged in:
Authors: Reviewers: Paul-Olivier Dehaye
Report Upstream: Completely fixed; Fix reported upstream Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Following files are present: sympy/src/doc/.DS_Store sympy/src/doc/src/.DS_Store sympy/src/doc/src/modules/.DS_Store sympy/src/doc/src/modules/mpmath/.DS_Store

Should this be reported upstream?

Change History (19)

comment:2 Changed 9 years ago by pdehaye

  • Status changed from new to needs_review

comment:3 Changed 9 years ago by kcrisman

  • Authors set to Paul-Olivier Dehaye

Reporting upstream sounds good. I'm not sure whether https://github.com/sympy/sympy/issues or http://code.google.com/p/sympy/issues/list is better.

comment:4 Changed 9 years ago by kcrisman

I think that in this case we should update the spkg scripts a bit more. There isn't much point in removing this by hand when the get_orig_sources script will just do it again.

Also, I think that nowadays such scripts are called spkg-create or something like that... I can't remember, though, and the developer guide doesn't have it, of course. Certainly the README is ancient (hg log says 2008); that information should be in SPKG.txt in any case.

comment:5 Changed 8 years ago by kcrisman

  • Status changed from needs_review to needs_work
  • Work issues set to update script or get changed upstream

comment:6 follow-up: Changed 8 years ago by kcrisman

  • Status changed from needs_work to needs_review

Well, I looked at a clean source and these files aren't there, so they must have gotten added when a Sage developer on Mac wasn't careful about this. Maybe the sage-pkg script needs to do a ls -aR | grep DS_Store or something.

Anyway, I'm putting this back to 'needs review' because of this.

comment:7 in reply to: ↑ 6 Changed 8 years ago by jdemeyer

Replying to kcrisman:

Well, I looked at a clean source and these files aren't there, so they must have gotten added when a Sage developer on Mac wasn't careful about this.

No, the .DS_Store files are upstream in http://sympy.googlecode.com/files/sympy-0.7.1.tar.gz

This should be either reported upstream or closed as "wontfix" (I won't do neither of these).

comment:8 Changed 8 years ago by kcrisman

  • Report Upstream changed from N/A to Reported upstream. No feedback yet.
  • Status changed from needs_review to needs_work

Thanks, Jeroen - I used the wrong command before. In Sympy 0.7.2, we have

$ ls -aR . | grep -C 4 DS_Store

./data:
.
..
.DS_Store
IPython
Macports
TeXmacs

--

./doc:
.
..
.DS_Store
Makefile
README.rst
api
apidoc.conf
--

./doc/src:
.
..
.DS_Store
_static
aboutus.rst
conf.py
figures

so different garbage, but still there.

Reported upstream at Sympy issue 3787.

I now agree that we either need a script in spkg-install to avoid this or to wait on upstream. Is there any problem if we also upgrade at this ticket, should that work?

comment:9 Changed 8 years ago by kcrisman

  • Report Upstream changed from Reported upstream. No feedback yet. to Reported upstream. Developers acknowledge bug.

comment:10 Changed 8 years ago by kcrisman

  • Priority changed from major to minor

They say that Sympy issue 3445, where they automate the release process, would take care of this. We'll see.

Since my original comment

I think that in this case we should update the spkg scripts a bit more. There isn't much point in removing this by hand when the get_orig_sources script will just do it again.

now stands again, I am putting this back to "needs work". And it is clearly not particularly major.

comment:11 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:12 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:14 Changed 7 years ago by jdemeyer

  • Authors Paul-Olivier Dehaye deleted
  • Milestone changed from sage-6.2 to sage-duplicate/invalid/wontfix
  • Reviewers set to Paul-Olivier Dehaye
  • Status changed from needs_work to positive_review
  • Work issues update script or get changed upstream deleted

I think this can be closed since we longer use spkg's.

comment:15 follow-up: Changed 7 years ago by kcrisman

  • Status changed from positive_review to needs_info

Except we do still take upstream, and if it has garbage, it should be removed. I don't think it's there any more, but it's worth checking. Does https://github.com/sympy/sympy/pull/2256 indeed take care of it?

comment:16 in reply to: ↑ 15 ; follow-up: Changed 7 years ago by jdemeyer

  • Status changed from needs_info to positive_review

Replying to kcrisman:

Except we do still take upstream, and if it has garbage, it should be removed

...by upstream, so this is not a Sage bug.

comment:17 in reply to: ↑ 16 ; follow-up: Changed 7 years ago by kcrisman

Except we do still take upstream, and if it has garbage, it should be removed

...by upstream, so this is not a Sage bug.

Well, fine, but we do fix upstream bugs until they're fixed upstream. Anyway, as long as it's been handled there I have no interest in it, just trying to make sure that is confirmed (as we do for other upstream tickets).

comment:18 in reply to: ↑ 17 Changed 7 years ago by jdemeyer

Replying to kcrisman:

Except we do still take upstream, and if it has garbage, it should be removed

...by upstream, so this is not a Sage bug.

Well, fine, but we do fix upstream bugs until they're fixed upstream.

True, but is this even a bug? A few extra files which do nothing wrong, take almost no space and don't do anything wrong.

comment:19 Changed 7 years ago by vbraun

  • Report Upstream changed from Reported upstream. Developers acknowledge bug. to Completely fixed; Fix reported upstream
  • Resolution set to fixed
  • Status changed from positive_review to closed

Its still wrong to have unrelated crap in your tarball. But its gone in sympy-0.7.4 which we currently use.

Note: See TracTickets for help on using tickets.