Opened 9 years ago

Closed 7 years ago

#13585 closed defect (duplicate)

"full_output.txt" doesn't update on notebook

Reported by: dox Owned by: dox
Priority: trivial Milestone: sage-duplicate/invalid/wontfix
Component: notebook Keywords: notebook, full_output, http, cache
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

Since the full_output.txt files generated by the notebook are often changed, the client web browser should always ask for a new version instead of retrieving a cached version.

We need to add the right HTTP headers to instruct the browser to always request a new version of full_output.txt from the server.

Change History (10)

comment:1 follow-up: Changed 9 years ago by nbruin

Are you sure it doesn't update? Are you requesting an explicit reload from your browser? As an example: If I do

for i in range(1000):
    print i

in the notebook and click full_output.txt I get the output as requested (in a new tab).

If I now change the same cell:

 for i in range(1000):
-    print i
+    print i^2

the tab full_output.txt doesn't change when I use firefox. This is because newer versions of Firefox, when asked to open a URL that is already open in some tab or window, will just change to that tab/window; it does not reload the content. Once I explicitly ask to reload that file, I do get the updated output.

The above behaviour is not a bug in Sage. It's an issue with Firefox and it's probably considered a feature. There may be a setting in about:config to influence this behaviour. Probably other browsers have similar behaviour.

If your observations do not agree with what is described above, please describe them.

comment:2 in reply to: ↑ 1 Changed 9 years ago by dox

You are write! I'm sorry didn't noticed before.

comment:3 Changed 9 years ago by dox

  • Priority changed from major to trivial
  • Report Upstream changed from N/A to Completely fixed; Fix reported upstream

comment:4 Changed 7 years ago by kcrisman

  • Milestone changed from sage-wishlist to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

According to this discussion, I think this should be closed.

comment:5 Changed 7 years ago by kcrisman

  • Status changed from needs_review to positive_review

comment:6 Changed 7 years ago by jdemeyer

  • Description modified (diff)
  • Milestone changed from sage-duplicate/invalid/wontfix to sage-6.4
  • Report Upstream changed from Completely fixed; Fix reported upstream to N/A
  • Status changed from positive_review to needs_work

This issue hasn't been fixed, I'm updating the description.

comment:7 Changed 7 years ago by jdemeyer

  • Description modified (diff)

comment:8 Changed 7 years ago by jdemeyer

  • Keywords http cache added; update removed

comment:9 Changed 7 years ago by kcrisman

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Status changed from needs_work to positive_review

Well, then maybe see #14633, since there were three tickets that were opened about this same issue? I'll put your comments there and the relevant upstream ticket.

comment:10 Changed 7 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.