Opened 9 years ago

Closed 6 years ago

#13577 closed defect (duplicate)

cdef _richcmp is overridden by def method

Reported by: SimonKing Owned by: GeorgSWeber
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

sage/structure/parent_old.pxd defines:

cdef class Parent(parent.Parent):
    ...
    # Comparison of parent objects
    cdef _richcmp(left, right, int op)

But sage.structure.parent_base.ParentWithBase? overrides it:

cdef class ParentWithBase(parent_old.Parent):
    ...
    def _richcmp(left, right, int op):
        check_old_coerce(left)
        return (<parent_old.Parent>left)._richcmp(right, op) # the cdef method

The result is a warning when compiling sage.structure.parent_base.

Does that need fixing? I am not sure. Also I am not sure about the bug component. Perhaps "build", because the only "problem" seems to be a warning while building sage?

Change History (8)

comment:1 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:2 Changed 8 years ago by SimonKing

Note to myself: Fix this.

comment:3 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:4 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:5 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:6 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

This is very likely a duplicate of #17890.

comment:7 Changed 6 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:8 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.