Opened 9 years ago

Closed 7 years ago

#13536 closed defect (fixed)

Password recovery doesn't work in the new flask notebook

Reported by: mmarco Owned by: jason, mpatel, was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: notebook Keywords: notebook authentication
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: Completely fixed; Fix reported upstream Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

When you try to recover a forgotten password in the new notebook, you are asked for the username, and then get the response "invalid username" even if the username is valid, and the email has been confirmed.

Attachments (1)

trac_13536.patch (678 bytes) - added by mmarco 9 years ago.

Download all attachments as: .zip

Change History (17)

Changed 9 years ago by mmarco

comment:1 follow-up: Changed 9 years ago by kcrisman

  • Reviewers set to Karl-Dieter Crisman
  • Status changed from new to needs_review

I think this is fixed upstream. See the upstream master.

comment:2 Changed 9 years ago by kcrisman

  • Milestone changed from sage-5.4 to sage-duplicate/invalid/wontfix
  • Report Upstream changed from N/A to Fixed upstream, in a later stable release.
  • Status changed from needs_review to positive_review

This is in fact already in #13121 and so this is invalid.

comment:3 in reply to: ↑ 1 Changed 9 years ago by mmarco

Replying to kcrisman:

I think this is fixed upstream. See the upstream master.

Upstream is still broken.The line that you point (and other lines that make things not work) coincide with the current version included in sage 5.3

comment:4 Changed 9 years ago by kcrisman

  • Milestone changed from sage-duplicate/invalid/wontfix to sage-5.4
  • Reviewers Karl-Dieter Crisman deleted
  • Status changed from positive_review to needs_work

Oops, you're right - I read the patch backward!

However, this is a pretty easy thing to make a pull request for. It turns out you can even do it more or less anonymously by clicking on the code itself and changing it... I'll try later this morning if I find time.

comment:5 Changed 9 years ago by kcrisman

  • Report Upstream changed from Fixed upstream, in a later stable release. to Not yet reported upstream; Will do shortly.

comment:6 Changed 9 years ago by kcrisman

  • Report Upstream changed from Not yet reported upstream; Will do shortly. to Reported upstream. No feedback yet.
  • Status changed from needs_work to needs_review

comment:7 Changed 9 years ago by jdemeyer

I prefer sagenb-only tickets such as this should be on sagenb github and only there. Even if this patch is positively reviewed, there is nothing I can do since sagenb has been separated from Sage. So, I would like to close this as "invalid" and refer to github instead.

comment:8 Changed 9 years ago by jdemeyer

  • Milestone changed from sage-5.4 to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from needs_review to positive_review

comment:9 follow-up: Changed 9 years ago by kcrisman

  • Status changed from positive_review to needs_info

Hmm, I don't know about this. We have tickets all the time for things in upstream packages. Then we say "fixed by spkg in #abcde" and say "close when #abcde is merged". Or sometimes even have an spkg right on the ticket. Why should sagenb be any different?

comment:10 in reply to: ↑ 9 Changed 9 years ago by jdemeyer

Replying to kcrisman:

Hmm, I don't know about this. We have tickets all the time for things in upstream packages. Then we say "fixed by spkg in #abcde" and say "close when #abcde is merged". Or sometimes even have an spkg right on the ticket. Why should sagenb be any different?

Because we usually don't update sagenb for every single ticket. Also, sagenb upstream is different because we don't patch the sagenb spkg in Sage.

comment:11 follow-up: Changed 9 years ago by ppurka

I asked this question in github: I can't seem to get a "forgot password" link from the login page. Same problem is on sagenb.org. Where is this link that we are trying to fix here?

comment:12 in reply to: ↑ 11 Changed 9 years ago by kcrisman

  • Report Upstream changed from Reported upstream. No feedback yet. to Fixed upstream, but not in a stable release.

Replying to ppurka:

I asked this question in github: I can't seem to get a "forgot password" link from the login page. Same problem is on sagenb.org. Where is this link that we are trying to fix here?

See the github pull request, where Jason points out this only happens when we ask for an email address. Anyway, it's been merged upstream in master, so now we just need to wait for a new sagenb package to make this ticket depend on! "Needs info" for that (eventual) ticket.

comment:13 Changed 7 years ago by aapitzsch

  • Status changed from needs_info to needs_review

Fix is part of sagenb since version 0.10.3. We are using version 0.10.8 (#15569). So let's get this ticket closed.

comment:14 Changed 7 years ago by ppurka

  • Report Upstream changed from Fixed upstream, but not in a stable release. to Completely fixed; Fix reported upstream

Just set it to positive review, then close it as invalid.

comment:15 Changed 7 years ago by aapitzsch

  • Status changed from needs_review to positive_review

comment:16 Changed 7 years ago by vbraun

  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.