Opened 9 years ago

Closed 6 years ago

#13456 closed defect (duplicate)

Coercion from numpy matrix to GF() is wrong

Reported by: ppurka Owned by: jason, was
Priority: major Milestone: sage-6.5
Component: linear algebra Keywords: numpy coercion
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Essentially, this:

sage: import numpy
sage: A = matrix(GF(2), numpy.array([[0, 1], [0,1]]))
sage: A + A
[0 2]
[0 2]

Change History (7)

comment:1 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:2 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:3 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:4 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:5 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-6.4 to sage-6.5
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Duplicate of #12287.

comment:6 Changed 6 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:7 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.