Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#13428 closed defect (fixed)

Race condition in R installation

Reported by: jdemeyer Owned by: tbd
Priority: critical Milestone: sage-5.4
Component: packages: standard Keywords: R spkg
Cc: jhpalmieri Merged in: sage-5.4.beta1
Authors: Jeroen Demeyer Reviewers: John Palmieri
Report Upstream: Fixed upstream, in a later stable release. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

The following seems to occur only on OS X systems. When building R in parallel, sometimes the following can happen:

[...]
mkdir /Users/jdemeyer/sage-5.3.rc0/local/lib/R/bin
mkdir /Users/jdemeyer/sage-5.3.rc0/local/lib/R/include
mkdir: /Users/jdemeyer/sage-5.3.rc0/local/lib/R/include: File exists
make[2]: *** [installdirs] Error 1
make[1]: *** [install] Error 1
make: *** [install] Error 1
Error installing R.

The problem is that libintl.h has been copied to the file /Users/jdemeyer/sage-5.3.rc0/local/lib/R/include.

Reported upstream: https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=15041

spkg: http://boxen.math.washington.edu/home/jdemeyer/spkg/r-2.14.0.p4.spkg

Attachments (1)

r-2.14.0.p4.diff (1.6 KB) - added by jdemeyer 7 years ago.
Diff for the R spkg. For reference / review only.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 7 years ago by jdemeyer

  • Cc jhpalmieri added

comment:2 Changed 7 years ago by jdemeyer

  • Description modified (diff)
  • Report Upstream changed from N/A to Reported upstream. No feedback yet.

comment:3 Changed 7 years ago by jdemeyer

  • Status changed from new to needs_review

Changed 7 years ago by jdemeyer

Diff for the R spkg. For reference / review only.

comment:4 Changed 7 years ago by jhpalmieri

  • Reviewers set to John Palmieri
  • Status changed from needs_review to positive_review

The patch makes sense and this fixes the problem for me.

comment:5 Changed 7 years ago by jdemeyer

  • Merged in set to sage-5.4.beta1
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:6 Changed 7 years ago by kcrisman

  • Report Upstream changed from Reported upstream. No feedback yet. to Fixed upstream, but not in a stable release.

The bug is now marked as closed and fixed, though I haven't got the foggiest in what version, since they don't mention this.

comment:7 Changed 7 years ago by jdemeyer

  • Report Upstream changed from Fixed upstream, but not in a stable release. to Fixed upstream, in a later stable release.

Fixed in #14008.

Note: See TracTickets for help on using tickets.