Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#13408 closed defect (worksforme)

atlas-3.8.4 package does not compile on rhel 5 systems, upgrade to atlas-3.10.0

Reported by: jrasch Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords: atlas
Cc: Merged in:
Authors: Reviewers: Karl-Dieter Crisman
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

Compilation of Sage-5.2 fails with an error inside the atlas-3.8.4 package. However the latest atlas-3.10.0 version compiles fine. I therefore propose that the package be updated to the latest release for the next release of sage.

For further details see also the post: http://groups.google.com/group/sage-devel/browse_thread/thread/3ef74904a5e321b4#

Change History (7)

comment:1 Changed 9 years ago by jrasch

  • Description modified (diff)

comment:2 Changed 9 years ago by kcrisman

  • Reviewers set to Karl-Dieter Crisman
  • Status changed from new to needs_review

My sense is that this is a dup of #10508. Can you try the spkg posted there?

Last edited 9 years ago by kcrisman (previous) (diff)

comment:3 Changed 8 years ago by kcrisman

Ping - that spkg has now apparently reached final form. I don't know how many people have access to an RHEL system.

comment:4 Changed 8 years ago by jdemeyer

  • Description modified (diff)
  • Milestone changed from sage-5.4 to sage-duplicate/invalid/wontfix
  • Resolution set to worksforme
  • Status changed from needs_review to closed

The buildbot machine "rosemary" has RHEL 5.8 (the problematic version according to the sage-devel post), but atlas-3.8.4 builds fine on that machine. Skynet machine cleo also has RHEL IIRC but it's unaccessible now.

comment:5 follow-up: Changed 8 years ago by kcrisman

OP:

on the latest HP 
ProLiant ml110 G7 system

Do you think that the actual machine hardware would make a difference?

comment:6 in reply to: ↑ 5 Changed 8 years ago by jdemeyer

Replying to kcrisman:

OP:

on the latest HP 
ProLiant ml110 G7 system

Do you think that the actual machine hardware would make a difference?

I have no idea. The original poster is unresponsive, so it's hard to find out. Since the problem is fixed by upstream atlas-3.10.0, let's assume #10508 also fixes it.

comment:7 Changed 8 years ago by kcrisman

Cool.

Note: See TracTickets for help on using tickets.