Opened 7 years ago

Closed 7 years ago

#13350 closed defect (fixed)

Cannot import rpy2.rinterface.rinterface on Cygwin

Reported by: jpflori Owned by: tbd
Priority: major Milestone: sage-5.7
Component: porting: Cygwin Keywords: cygwin r rpy2
Cc: kcrisman Merged in: sage-5.7.beta0
Authors: Jean-Pierre Flori Reviewers: Karl-Dieter Crisman
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jpflori)

cygchecking the corresponding dll shows that libR.dll cannot be found. Indeed, it resides in SAGE_LOCAL/lib/R/lib/ which is not part of PATH. Adding it to path seems to fix the issue.

Apply trac_13350.patch to SAGE_ROOT.

Attachments (1)

trac_13350.patch (592 bytes) - added by jpflori 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by jpflori

comment:1 Changed 7 years ago by jpflori

  • Authors set to Jean-Pierre Flori
  • Description modified (diff)
  • Status changed from new to needs_review

comment:2 Changed 7 years ago by kcrisman

  • Cc kcrisman added

comment:3 Changed 7 years ago by kcrisman

  • Reviewers set to Karl-Dieter Crisman
  • Status changed from needs_review to positive_review

This fixes the problem, nice work.

comment:4 Changed 7 years ago by jdemeyer

  • Milestone changed from sage-5.6 to sage-5.7

comment:5 Changed 7 years ago by jdemeyer

  • Merged in set to sage-5.7.beta0
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.