Opened 7 years ago

Closed 7 years ago

#13340 closed defect (duplicate)

log scale plot fails if xmin > xmax

Reported by: ppurka Owned by: jason, was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: graphics Keywords:
Cc: kcrisman Merged in:
Authors: Reviewers: Punarbasu Purkayastha
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by ppurka)

Superseded by #13422


The summary. The problem is a simply a missing abs() function. Example:

plot(x,1,10).show(scale='loglog', xmin=10, xmax=1)

 File "/home/punarbasu/Installations/sage-5.2.trac/local/lib/python2.7/site-packages/sage/plot/graphics.py", line 1972, in _matplotlib_tick_formatter
    raise ValueError('Either expand the range of the independent '
ValueError: Either expand the range of the independent variable to allow two different integer powers of your `base`, or change your `base` to a smaller number.

Attachments (1)

trac_13340-fix_logscale_xmin_xmax.patch (2.0 KB) - added by ppurka 7 years ago.
Apply to devel/sage

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by ppurka

Apply to devel/sage

comment:1 Changed 7 years ago by ppurka

  • Authors set to Punarbasu Purkayastha
  • Description modified (diff)
  • Status changed from new to needs_review

comment:2 Changed 7 years ago by ppurka

  • Cc kcrisman added

You are probably interested in this patch. Not sure how I missed it in #4529 :)

comment:3 Changed 7 years ago by ppurka

  • Description modified (diff)
  • Status changed from needs_review to positive_review

comment:4 follow-up: Changed 7 years ago by ppurka

Someone close this as invalid :(

comment:5 in reply to: ↑ 4 ; follow-up: Changed 7 years ago by kcrisman

Someone close this as invalid :(

The issue as described seems orthogonal to #13340. Are you saying it's fixed there? I wouldn't say invalid so much as a dup then.

comment:6 in reply to: ↑ 5 Changed 7 years ago by ppurka

Replying to kcrisman:

Someone close this as invalid :(

The issue as described seems orthogonal to #13340. Are you saying it's fixed there? I wouldn't say invalid so much as a dup then.

Ok. A dupe then. It is fixed way more cleanly in #13422.

comment:7 Changed 7 years ago by kcrisman

  • Authors Punarbasu Purkayastha deleted
  • Milestone changed from sage-5.3 to sage-duplicate/invalid/wontfix
  • Reviewers set to Punarbasu Purkayastha

comment:8 Changed 7 years ago by kcrisman

In the future, if you perceive an obvious dup, you can set the milestone as I have and make it positive review so that the release manager sees it.

comment:9 Changed 7 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.