Opened 9 years ago

Closed 5 years ago

#13288 closed defect (wontfix)

Polyhedron plot absorbs point3d elements incorrectly when summed

Reported by: kcrisman Owned by: jason, was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: graphics Keywords:
Cc: Merged in:
Authors: Reviewers: Frédéric Chapoton
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

This plots fine.

Z = Polyhedron([[2,3,3],[3,0,3],[2,6,1],[1,0,1],[6,7,2]])
z = Z.plot()
z

Now try adding a point.

z+point3d((0,0,0),size=30,color='red')

This looks fine too.

z

And now we've added a point to the polyhedron!

This was originally noticed at this ask.sagemath.org question inside an interact, where, as one might imagine, it would be particularly annoying.

Change History (10)

comment:1 Changed 9 years ago by jason

I think this is probably nothing more than a manifestation of #9089

comment:2 Changed 9 years ago by kcrisman

  • Type changed from PLEASE CHANGE to defect

Hmm, I bet you're right. How about you update the patch there and we find out ;-)

comment:3 Changed 9 years ago by jason

When I get time...

comment:4 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:5 Changed 8 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:6 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:7 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:8 Changed 5 years ago by mkoeppe

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Reviewers set to marked as invalid - please review
  • Status changed from new to needs_review

No problem with the red point in 7.4.beta0, though plotting the polyhedron is broken with the Java-based jmol (#20978).

comment:9 Changed 5 years ago by chapoton

  • Reviewers changed from marked as invalid - please review to Frédéric Chapoton
  • Status changed from needs_review to positive_review

ok, also works for me in 7.4.b1

comment:10 Changed 5 years ago by embray

  • Resolution set to wontfix
  • Status changed from positive_review to closed

Determined to be invalid/duplicate/wontfix (closing as "wontfix" as a catch-all resolution).

Note: See TracTickets for help on using tickets.