Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#13263 closed defect (duplicate)

matrix() for elements in quotients of polynomial ring broken over inexact rings

Reported by: saraedum Owned by: malb
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: commutative algebra Keywords: padic, quotient ring, inexact ring
Cc: Merged in:
Authors: Reviewers: Julian Rueth, Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The following code fails:

sage: R.<T>=Qp(3,prec=2)[]
sage: S.<Tbar>=R.quo(T^2+1)
sage: S(T^2).matrix()
TypeError: cannot construct an element of Full MatrixSpace of 2 by 2 dense matrices over 3-adic Field with capped relative precision 2 from [2 + 2*3 + O(3^2), 0, O(3^2), 0, 2 + 2*3 + O(3^2), 0, O(3^2)]!
sage: S(T^2)
(O(3^2))*Tbar^2 + (2 + 2*3 + O(3^2))

The term (O(3^2))*Tbar^2 should not be present since we modded out by T^2+1.

Attachments (1)

trac_13263.patch (4.8 KB) - added by saraedum 9 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by saraedum

comment:1 Changed 9 years ago by saraedum

  • Status changed from new to needs_review

comment:2 Changed 9 years ago by saraedum

  • Authors set to Julian Rueth

comment:3 Changed 8 years ago by tscrim

  • Milestone changed from sage-5.9 to sage-duplicate/invalid/wontfix

I believe this is a duplicate of #13662.

comment:4 Changed 8 years ago by saraedum

  • Status changed from needs_review to positive_review

comment:5 Changed 8 years ago by jdemeyer

  • Resolution set to duplicate
  • Reviewers set to Travis Scrimshaw
  • Status changed from positive_review to closed

comment:6 Changed 8 years ago by jdemeyer

  • Authors Julian Rueth deleted
  • Reviewers changed from Travis Scrimshaw to Julian Rueth, Travis Scrimshaw
Note: See TracTickets for help on using tickets.