Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#13182 closed defect (fixed)

Update sage-mode to 0.9.1

Reported by: iandrus Owned by: was
Priority: major Milestone: sage-5.10
Component: packages: optional Keywords: sage-mode
Cc: hivert, bump, jpflori Merged in:
Authors: Ivan Andrus Reviewers: Frédéric Chapoton
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by iandrus)

After updating to 0.7 in #13176 we should move to the latest release.

The 0.9.1 spkg is at https://bitbucket.org/gvol/sage-mode/downloads/sage_mode-0.9.1.spkg

Version 0.8 includes support python.el by fgallina which will is in Emacs 24.2.

Version 0.9 includes improved sage-view rendering and, importantly, support the new ipython. Without 0.9 simple things such as tab completion are completely broken in Sage 5.7 and later.

Version 0.9.1 Fixes some problems reported on this ticket.

Change History (30)

comment:1 Changed 9 years ago by iandrus

  • Description modified (diff)

comment:2 Changed 9 years ago by iandrus

  • Status changed from new to needs_review

I have released sage-mode 0.8, so I'm marking this as needs review. Please reinstall the sage_mode spkg from the link in the description before reviewing.

comment:3 Changed 8 years ago by ddrake

If nothing else, I'm happy that the name of the spkg now has an underscore (sage_mode instead of sage-mode). This may seem unimportant, but the usual "sage -i" command gets confused when the spkg name has a hyphen in it (some script splits on the hyphen to separate the name from the version number). So thanks for the name change!

I'll look over the spkg but my elisp knowledge is probably too minimal to properly review this, and I'm also stuck with Emacs 23 for now.

comment:4 Changed 8 years ago by iandrus

Since this is technically an upstream package (and still optional) I don't know that you need to check the elisp so much as just make sure that it installs, and works correctly. Though of course feedback on the elisp is welcome too.

There is a known issue with new versions of Sage and pretty printing output.

comment:5 Changed 8 years ago by iandrus

  • Description modified (diff)

comment:6 Changed 8 years ago by nthiery

I can confirm that 0.9 installed and ran smoothly on my machine (Ubuntu 12.04, emacs 23.3). And given that it fixes a critical issue (tab completion) with the latest version of Sage, I am all in favor for getting this in! Thanks for name change as well.

comment:7 Changed 8 years ago by iandrus

  • Description modified (diff)
  • Summary changed from Update sage-mode to 0.8 to Update sage-mode to 0.9
  • Type changed from enhancement to defect

I have updated slightly the 0.9 package and made an official release. Since 0.7 is broken wrt newer versions of Sage I have changed this to a defect.

comment:8 Changed 8 years ago by hivert

  • Cc hivert added

comment:9 Changed 8 years ago by ddrake

I've installed the 0.9 spkg into 5.9.beta0 on Ubuntu 12.10 (with emacs 23.4) and things seem to work fine. I'm going to try with emacs 24 and report how that works.

comment:10 Changed 8 years ago by ddrake

The AUCTeX integration is great! But I do notice one problem with emacs 24:

If you don't have org-mode installed and you load a TeX file -- with or without any Sage stuff in it -- I get "Can't find library org". If I then install org-mode, loading a TeX file gives File mode specification error: (void-function loop).

This is with the current state of Ubuntu 13.04: emacs 24.2, AUCTeX 11.87 and org-mode 7.9.2. In Ubuntu 12.10 (versions 23.4, 11.86, 7.8.11, respectively) things work fine.

comment:11 Changed 8 years ago by iandrus

The loop problem is because I forgot to require cl at compile time. I'm not sure why loading a tex file asks for org--it definitely shouldn't. I tried it real fast, but I couldn't reproduce it. If you uninstall org and set debug-on-error do you get a backtrace?

comment:12 Changed 8 years ago by iandrus

I have a fix for the loop issue up on bitbucket (not sure why I didn't think of hosting spkg's there before).

comment:13 follow-up: Changed 8 years ago by ddrake

Backtrace for the problem when org isn't installed: http://boxen.math.washington.edu/home/drake/13182load-tex-file-backtrace.txt . Your 0.9.1 spkg fixes the loop problem when I have org-mode installed in emacs 24.

comment:14 in reply to: ↑ 13 Changed 8 years ago by iandrus

  • Description modified (diff)

Replying to ddrake:

Backtrace for the problem when org isn't installed: http://boxen.math.washington.edu/home/drake/13182load-tex-file-backtrace.txt . Your 0.9.1 spkg fixes the loop problem when I have org-mode installed in emacs 24.

This seems to be a bug in org-mode (the version that's shipped with your emacs). It's finding some org files (in particular org-latex), but can't actually (require 'org). Normally org wouldn't be loaded at run time, only at compile time, but since byte-compilation failed (due to this error), it also occurred at run time. I have updated the spkg on bitbucket to work around this issue (I hope).

Thanks for testing.

comment:15 Changed 8 years ago by iandrus

  • Description modified (diff)
  • Summary changed from Update sage-mode to 0.9 to Update sage-mode to 0.9.1

comment:16 follow-up: Changed 8 years ago by nthiery

Hi!

Would it be possible to add

    (require 'help-mode)

See: http://www.mail-archive.com/sage-devel@googlegroups.com/msg41622.html

Thanks!

comment:17 in reply to: ↑ 16 Changed 8 years ago by iandrus

Replying to nthiery:

Hi!

Would it be possible to add

    (require 'help-mode)

See: http://www.mail-archive.com/sage-devel@googlegroups.com/msg41622.html

Thanks!

It's on line 70 of sage-mode.el. Are you still seeing problems?

comment:18 follow-up: Changed 8 years ago by nthiery

  • Cc bump added

Ah. I posted this after seeing an issue on Dan Bump's machine; however I did not double check he had the very latest version of the spkg. I am adding him in CC for confirmation.

comment:19 in reply to: ↑ 18 ; follow-up: Changed 8 years ago by nthiery

Replying to nthiery:

Ah. I posted this after seeing an issue on Dan Bump's machine; however I did not double check he had the very latest version of the spkg. I am adding him in CC for confirmation.

I reinstalled the latest sage-mode on my machine, after removing the "require help-mode" line from my .emacs, and this indeed seems to work smootlhy. Dan, can you confirm?

comment:20 in reply to: ↑ 19 Changed 8 years ago by ddrake

Replying to nthiery:

I reinstalled the latest sage-mode on my machine, after removing the "require help-mode" line from my .emacs, and this indeed seems to work smootlhy. Dan, can you confirm?

I can confirm that the latest spkg works. It has a (require 'help-mode) line, my .emacs does not, and everything installs and works fine with emacs 23.

comment:21 Changed 8 years ago by jpflori

  • Cc jpflori added

comment:22 Changed 8 years ago by iandrus

I hate to bug everyone, but it would be great if this could get reviewed. I keep getting emails from people having problems and they are (understandably) still using sage-mode 0.7. It's not uncommon that their issues are solved by simply upgrading.

Thanks, and let me know if I can review one of your tickets in exchange or something.

comment:23 follow-up: Changed 8 years ago by chapoton

I have tried on sage 5.10.rc1, and it works fine.

In particular, tab completion works.

I had to install preview-latex-style, which is not by default on my ubuntu LTS.

I would give a positive review, but I would prefer if Nicolas or Florent confirm me !

comment:24 in reply to: ↑ 23 Changed 8 years ago by iandrus

Replying to chapoton:

I have tried on sage 5.10.rc1, and it works fine.

In particular, tab completion works.

I had to install preview-latex-style, which is not by default on my ubuntu LTS.

I would give a positive review, but I would prefer if Nicolas or Florent confirm me !

You mean you had to install preview.sty? You should only need that to use sage-view to display typeset text. But it would probably be a good idea to mention that as a requirement. I'll add it to the next version.

comment:25 follow-up: Changed 8 years ago by chapoton

Using the skpg with emacs 23, I have only been hurted by problems with latex compilation, which are part of other tickets, namely #14382 and #13624.

So let me give a positive review.

comment:26 Changed 8 years ago by chapoton

  • Status changed from needs_review to positive_review

comment:27 Changed 8 years ago by jdemeyer

  • Component changed from user interface to packages: optional

comment:28 Changed 8 years ago by jdemeyer

  • Resolution set to fixed
  • Reviewers set to Frédéric Chapoton
  • Status changed from positive_review to closed

comment:29 Changed 8 years ago by schilly

optional spkg is on the server

comment:30 in reply to: ↑ 25 Changed 8 years ago by iandrus

Replying to chapoton:

Using the skpg with emacs 23, I have only been hurted by problems with latex compilation, which are part of other tickets, namely #14382 and #13624.

So let me give a positive review.

Cool, thanks!

Note: See TracTickets for help on using tickets.