Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#13144 closed defect (duplicate)

Fix Sympow on FreeBSD

Reported by: kcrisman Owned by: pjeremy
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting: BSD Keywords:
Cc: pjeremy Merged in:
Authors: Reviewers: Stephen Montgomery-Smith
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by chapoton)

For the current FreeBSD port, the following patch is necessary. See this sage-devel thread where it was first reported.

  • sympow-1.018.1.p11/src/disk.

    old new  
    3939 else if (((sp&3)==0) && CM_CASE) {if (2*ep==sp) S[3]='l'; else S[3]='h';}
    4040 else {if (2*ep==sp) S[3]='L'; else S[3]='H';}
    4141 if (HECKE && dv) {TACKS[which]=malloc(dv*sizeof(QD)); TACKON[which]=dv;}
    42  else if (dv<=sp/2) TACKON[which]=0;
     42 else if (dv<=sp/2) {TACKS[which]=NULL; TACKON[which]=0;}
    4343 else {TACKS[which]=malloc((dv-sp/2)*sizeof(QD)); TACKON[which]=dv-sp/2;}
    4444 S[4]=0; F=fopen("datafiles/param_data","r"); strcpy(U,S);
    4545 if (ANAL_RANK) {if (dv>0) U[0]='A'; else U[0]='m';}

Presumably we would want to only apply this on FreeBSD for now. Needs an spkg.

Change History (5)

comment:1 Changed 10 years ago by stephen

It is a duplicate of

http://trac.sagemath.org/sage_trac/ticket/12858

I think this patch should be applied to all operating systems. I think it is just a matter of luck that other operating systems were not hit by this bug.

comment:2 Changed 10 years ago by kcrisman

  • Authors Stephen Montgomery-Smith deleted
  • Milestone changed from sage-5.2 to sage-duplicate/invalid/wontfix
  • Reviewers set to Stephen Montgomery-Smith
  • Status changed from new to needs_review

comment:3 Changed 10 years ago by kcrisman

  • Status changed from needs_review to positive_review

comment:4 Changed 10 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed

comment:5 Changed 6 years ago by chapoton

  • Description modified (diff)
Note: See TracTickets for help on using tickets.