Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#13129 closed defect (duplicate)

libSingular segmentation fault in factor

Reported by: vbraun Owned by: AlexGhitza
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: algebra Keywords:
Cc: burcin, malb Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: Fixed upstream, in a later stable release. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by chapoton)

As reported on sage-support (https://groups.google.com/d/topic/sage-support/03KsQOYOQOE/discussion):

sage: R.<t,x>=GF(2)['t,x']
sage: g=t^16*x + t^10*x + t^9*x + t^6*x + t^5 + t*x + x^2
sage: g.factor(proof=False)

Program received signal SIGSEGV, Segmentation fault.
CanonicalForm::operator= (this=0x2a9, cf=...) at cf_inline.cc:275
275 cf_inline.cc: No such file or directory.
in cf_inline.cc
Missing separate debuginfos, use: debuginfo-install atlas-3.8.4-1.fc16.x86_64 boost-test-1.47.0-6.fc16.x86_64 expat-2.1.0-1.fc16.x86_64 fontconfig-2.8.0-4.fc16.x86_64 glibc-2.14.90-24.fc16.7.x86_64 keyutils-libs-1.5.2-1.fc16.x86_64 krb5-libs-1.9.3-2.fc16.x86_64 libcom_err-1.41.14-2.fc15.x86_64 libgcc-4.6.3-2.fc16.x86_64 libselinux-2.1.6-6.fc16.x86_64 libstdc++-4.6.3-2.fc16.x86_64 libuuid-2.20.1-2.3.fc16.x86_64 ncurses-libs-5.9-2.20110716.fc16.x86_64 nss-softokn-freebl-3.13.4-1.fc16.x86_64 openssl-1.0.0j-1.fc16.x86_64
(gdb) bt
#0  CanonicalForm::operator= (this=0x2a9, cf=...) at cf_inline.cc:275
#1  0x00007fffd9c7a2ac in henselStep12 (F=..., factors=..., bufFactors=..., 
    diophant=<optimized out>, M=..., Pi=..., j=31) at facHensel.cc:1960
#2  0x00007fffd9c7bfc0 in henselLift12 (F=..., factors=..., l=32, Pi=..., 
    diophant=..., M=..., sort=true) at facHensel.cc:2070
#3  0x00007fffd9c3579b in sieveSmallFactors (G=<optimized out>, 
    uniFactors=..., degPat=..., H=..., diophant=..., Pi=..., M=..., 
    success=@0x7fffffff9e6e, d=32) at facFqBivar.cc:3932
#4  0x00007fffd9c36211 in henselLiftAndLatticeRecombi (G=..., 
    uniFactors=<optimized out>, alpha=..., degPat=<optimized out>)
    at facFqBivar.cc:4057
#5  0x00007fffd9c3f6bf in biFactorize (F=<optimized out>, info=...)
    at facFqBivar.cc:5492
#6  0x00007fffd9bbebac in FpBiFactorize (G=<optimized out>) at facFqBivar.h:253
#7  0x00007fffd9bb811f in FpFactorize (F=...) at facFqFactorize.h:101
#8  factorize (f=..., issqrfree=<optimized out>) at cf_factor.cc:561
#9  0x00007fffd9a2e60a in singclap_factorize (f=0x7fffd98623a0, 
    v=0x7fffffffbc40, with_exps=0) at clapsing.cc:829
#10 0x00007fffd9fcc9f9 in __pyx_pf_4sage_5rings_10polynomial_28multi_polynomial_libsingular_23MPolynomial_libsingular_49factor (__pyx_v_self=0x46b46e0, 
    __pyx_args=<optimized out>, __pyx_kwds=<optimized out>)
    at sage/rings/polynomial/multi_polynomial_libsingular.cpp:25046

Looks like a Singular bug to me?

Change History (9)

comment:1 Changed 9 years ago by vbraun

  • Cc burcin malb added

comment:2 Changed 9 years ago by malb

  • Report Upstream changed from N/A to Fixed upstream, in a later stable release.

This is fixed in Singular 3-1-4-4.

comment:3 Changed 9 years ago by zimmerma

this is most probably a duplicate from #12918. See also #12928.

Paul Zimmermannn

comment:4 Changed 9 years ago by jdemeyer

  • Milestone changed from sage-5.3 to sage-duplicate/invalid/wontfix
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to needs_review

Fixed by #13237.

comment:5 Changed 9 years ago by jdemeyer

  • Status changed from needs_review to positive_review

comment:6 Changed 9 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed

comment:7 Changed 9 years ago by zimmerma

sorry, but I would like to see non-regression test in #13237 for this ticket, and similarly for other tickets solved by #13237.

Paul

comment:8 Changed 6 years ago by chapoton

  • Description modified (diff)

comment:9 Changed 6 years ago by chapoton

  • Description modified (diff)
Note: See TracTickets for help on using tickets.