Opened 7 years ago

Last modified 5 years ago

#13068 new defect

The VirtualBox image does not work on VMWare.

Reported by: ronanpaixao Owned by: jason
Priority: minor Milestone: sage-6.4
Component: misc Keywords: virtualbox, vmware, vm
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

The Virtualbox appliance does not work right away with VMWare.

When loading the .OVA into VMWare, it allows loading the appliance when relaxing the OVF specifications. However, when booting the machine, it gives an error and shuts itself down.

This is due to the Virtualbox Guest Additions coming preinstalled on the appliance image. This probably prevents the X server from loading and thus continues on the boot sequence, shutting down.

To work around this issue, one must, after installing the appliance, boot into recovery mode. On the prompt, one must execute the /opt/VBoxGuestAdditions<version>/uninstall.sh.

If you want to install VMWare Tools, shutdown the machine. Go to the VM's settings. On the Options tab, select General on the left list. On the right list, Guest operating system, select Linux and on the version, select Fedora. Click OK and power on the machine. On the boot menu, select the recovery option. On VMWare's menu (at least in case of VMWare Workstation), select VM->Install VMWare Tools. On the command prompt, execute the following commands:

mkdir /mnt/cdrom
mount /dev/cdrom1 /mnt/cdrom
cd ~
tar zxvf /mnt/cdrom/VMWareTools-<version>.tar.gz
vmware-tools-distrib/vmware-install.pl

Follow the instructions (usually means just hitting a lot of ENTER keys).

Reboot and enjoy.

  • This might be related to bug #11330, if one considers to also automatically build a VMWare appliance.

Change History (4)

comment:1 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:2 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:3 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:4 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4
Note: See TracTickets for help on using tickets.