Opened 8 years ago

Last modified 5 years ago

#13066 new enhancement

methods in Graphics are inconsistent

Reported by: ppurka Owned by: jason, was
Priority: minor Milestone: sage-6.4
Component: graphics Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by ppurka)

There is a lot of inconsistency between the methods in Graphics class. Is there any reason to not have the methods be better named? The old method names could be still kept around for backward compatibility.

  1. old_method -> new method(s)
  2. aspect_ratio -> get_aspect_ratio
  3. axes* -> get_axes*, set_axes*
  4. fontsize -> get_fontsize, set_fontsize
  5. -> set_minmax_data
  6. legend -> set_legend, get_legend
  7. -> get_legend_options
  8. tick_label_color -> set_tick_label_color, get_tick_label_color
  9. xmax/xmin/ymax/ymin -> get/set_xmax/xmin/ymax/ymin

The following methods are good:

  1. get/set_aspect_ratio
  2. get/set_axes_range
  3. set_legend_options

Actually, set_legend_options apparently works like get/set_legend_options depending on whether an input is provided.

Change History (5)

comment:1 Changed 8 years ago by ppurka

  • Description modified (diff)

comment:2 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:3 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:4 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:5 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4
Note: See TracTickets for help on using tickets.