Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#13027 closed enhancement (duplicate)

Upgrade and clean up IML

Reported by: kini Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords: iml
Cc: Merged in:
Authors: Reviewers: Keshav Kini
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

IML's SPKG is inordinately large because there's a 700KB full modified file in the patches/ directory rather than a patch. I will fix this, and while I'm at it, upgrade IML from 1.0.1 to 1.0.3.

Part of metaticket #13025.

Duplicate of #748.

Change History (15)

comment:1 Changed 9 years ago by kini

  • Description modified (diff)

comment:2 Changed 9 years ago by kini

Here's an SPKG - http://boxen.math.washington.edu/home/keshav/files/iml-1.0.3.p0.spkg

This may very well fail on OS X, given the dire comments (with lack of explanation) that were in SPKG.txt. Can someone test it?

comment:3 Changed 9 years ago by was

blastoff:sage-5.0.beta15 wstein$ ./sage -i ~/Downloads/iml-1.0.3.p0.spkg 
Calling sage-spkg on '/Users/wstein/Downloads/iml-1.0.3.p0.spkg'
iml-1.0.3.p0
====================================================
Extracting package /Users/wstein/Downloads/iml-1.0.3.p0.spkg
-rw-r--r--  1 wstein  staff  465370 May 27 10:04 /Users/wstein/Downloads/iml-1.0.3.p0.spkg
Finished extraction
****************************************************
Host system:
Darwin blastoff.westell.com 11.4.0 Darwin Kernel Version 11.4.0: Mon Apr  9 19:32:15 PDT 2012; root:xnu-1699.26.8~1/RELEASE_X86_64 x86_64
****************************************************
C compiler: gcc
C compiler version:
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/Users/wstein/sage/build/sage-5.0.beta15/local/libexec/gcc/x86_64-apple-darwin11.3.0/4.6.3/lto-wrapper
Target: x86_64-apple-darwin11.3.0
Configured with: ../src/configure --prefix=/Users/wstein/sage/build/sage-5.0.beta15/local --with-local-prefix=/Users/wstein/sage/build/sage-5.0.beta15/local --with-gmp=/Users/wstein/sage/build/sage-5.0.beta15/local --with-mpfr=/Users/wstein/sage/build/sage-5.0.beta15/local --with-mpc=/Users/wstein/sage/build/sage-5.0.beta15/local --with-system-zlib --disable-multilib  
Thread model: posix
gcc version 4.6.3 (GCC) 
****************************************************
patching file src/nullspace.c
patching file src/nullspace.c
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make -j6 sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make -j6... GNU
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking build system type... i686-apple-darwin11.4.0
checking host system type... i686-apple-darwin11.4.0
checking for a sed that does not truncate output... /usr/bin/sed
checking for ld used by gcc... ld
checking if the linker (ld) is GNU ld... no
checking for ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
rm: conftest.dSYM: is a directory
checking dependency style of g++... gcc3
checking how to run the C++ preprocessor... g++ -E
checking for g77... no
checking for f77... no
checking for xlf... no
checking for frt... no
checking for pgf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for f90... no
checking for xlf90... no
checking for pgf90... no
checking for epcf90... no
checking for f95... no
checking for fort... no
checking for xlf95... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for gfortran... gfortran
checking whether we are using the GNU Fortran 77 compiler... yes
checking whether gfortran accepts -g... yes
checking the maximum length of command line arguments... 196608
checking command to parse /usr/bin/nm output from gcc object... rm: conftest.dSYM: is a directory
rm: conftest.dSYM: is a directory
rm: conftest.dSYM: is a directory
rm: conftest.dSYM: is a directory
ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
rm: conftest.dSYM: is a directory
rm: conftest.dSYM: is a directory
checking if gcc supports -fno-rtti -fno-exceptions... rm: conftest.dSYM: is a directory
no
checking for gcc option to produce PIC... -fno-common
checking if gcc PIC flag -fno-common works... rm: conftest.dSYM: is a directory
yes
checking if gcc static flag -static works... rm: conftest.dSYM: is a directory
no
checking if gcc supports -c -o file.o... rm: conftest.dSYM: is a directory
yes
checking whether the gcc linker (ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin11.4.0 dyld
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
configure: creating libtool
appending configuration tag "CXX" to libtool
rm: conftest.dSYM: is a directory
rm: conftest.dSYM: is a directory
checking for ld used by g++... ld
checking if the linker (ld) is GNU ld... no
checking whether the g++ linker (ld) supports shared libraries... yes
checking for g++ option to produce PIC... -fno-common
checking if g++ PIC flag -fno-common works... rm: conftest.dSYM: is a directory
yes
checking if g++ static flag -static works... rm: conftest.dSYM: is a directory
no
checking if g++ supports -c -o file.o... rm: conftest.dSYM: is a directory
yes
checking whether the g++ linker (ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin11.4.0 dyld
checking how to hardcode library paths into programs... immediate
appending configuration tag "F77" to libtool
rm: conftest.dSYM: is a directory
rm: conftest.dSYM: is a directory
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for gfortran option to produce PIC... -fno-common
checking if gfortran PIC flag -fno-common works... rm: conftest.dSYM: is a directory
yes
checking if gfortran static flag -static works... rm: conftest.dSYM: is a directory
no
checking if gfortran supports -c -o file.o... rm: conftest.dSYM: is a directory
yes
checking whether the gfortran linker (ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin11.4.0 dyld
checking how to hardcode library paths into programs... immediate
./configure: line 18624: -g: command not found
checking for stdlib.h... (cached) yes
checking time.h usability... yes
checking time.h presence... yes
checking for time.h... yes
checking math.h usability... yes
checking math.h presence... yes
checking for math.h... yes
checking for an ANSI C-conforming const... yes
checking for size_t... yes
checking for stdlib.h... (cached) yes
checking for GNU libc compatible realloc... yes
checking for bzero... yes
checking for calloc... yes
checking for floor... yes
Default checking path = /usr /usr/local
checking for GMP >= 3.1.1... found
checking whether GMP is 4.0 or greater... yes
checking for ATLAS >= 3.0... not found
configure: error: ATLAS not found!
ATLAS version 3.0 or greater is required for this library to compile. Please make sure ATLAS is installed and specify the header and libraries location with the options --with-atlas-include=<path> and --with-atlas-lib=<path> respectively when running configure.

Error configuring IML

real	0m7.098s
user	0m2.427s
sys	0m3.218s
************************************************************************
Error installing package iml-1.0.3.p0
************************************************************************
Please email sage-devel (http://groups.google.com/group/sage-devel)
explaining the problem and including the relevant part of the log file
  /Users/wstein/sage/build/sage-5.0.beta15/spkg/logs/iml-1.

comment:4 Changed 9 years ago by kini

Awaiting access to bsd (the os x machine) for further testing...

comment:5 Changed 9 years ago by kini

Hmm. Well, I've managed to get it to configure. Apparently the old patches are still relevant. Next is to tackle the fact that repl doesn't build. It looks like this is caused by different command line syntax for ar on BSD compared to GNU ar:

make  all-recursive
Making all in repl
/bin/sh ../libtool --tag=CC --mode=link gcc  -I. -g -O2  -m64 -lm -o librepl.la     
mkdir .libs
ar cru .libs/librepl.a
ar: no archive members specified
usage:  ar -d [-TLsv] archive file ...
	ar -m [-TLsv] archive file ...
	ar -m [-abiTLsv] position archive file ...
	ar -p [-TLsv] archive [file ...]
	ar -q [-cTLsv] archive file ...
	ar -r [-cuTLsv] archive file ...
	ar -r [-abciuTLsv] position archive file ...
	ar -t [-TLsv] archive [file ...]
	ar -x [-ouTLsv] archive [file ...]
make[2]: *** [librepl.la] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
Error building IML

comment:6 Changed 9 years ago by kini

Correction: BSD ar doesn't allow empty .a files, whereas GNU ar does.

Last edited 9 years ago by kini (previous) (diff)

comment:7 Changed 9 years ago by kini

Update: I managed to work around this by downloading and installing the exact version of automake that the authors of IML used, adding a dummy C file which implements a simple do-nothing function, adding it to the source files for librepl in Makefile.am in the directory, and rebuilding Makefile.in (which will become Makefile when configure is run during build time).

Now the package configures and builds successfully on OS X, but does not pass tests:

creating test-largeentry
dyld: lazy symbol binding failed: Symbol not found: _cblas_dgemm
  Referenced from: /Users/wstein/build/sage-5.0/spkg/build/iml-1.0.3.p0/src/src/.libs/libiml.0.dylib
  Expected in: flat namespace

dyld: Symbol not found: _cblas_dgemm
  Referenced from: /Users/wstein/build/sage-5.0/spkg/build/iml-1.0.3.p0/src/src/.libs/libiml.0.dylib
  Expected in: flat namespace

/bin/sh: line 1: 74987 Trace/BPT trap          ${dir}$tst
FAIL: test-smallentry
dyld: lazy symbol binding failed: Symbol not found: _cblas_dgemm
  Referenced from: /Users/wstein/build/sage-5.0/spkg/build/iml-1.0.3.p0/src/src/.libs/libiml.0.dylib
  Expected in: flat namespace

dyld: Symbol not found: _cblas_dgemm
  Referenced from: /Users/wstein/build/sage-5.0/spkg/build/iml-1.0.3.p0/src/src/.libs/libiml.0.dylib
  Expected in: flat namespace

/bin/sh: line 1: 75006 Trace/BPT trap          ${dir}$tst
FAIL: test-largeentry
===================
2 of 2 tests failed
===================
make[2]: *** [check-TESTS] Error 1
make[1]: *** [check-am] Error 2
make: *** [check-recursive] Error 1
Error testing IML

comment:8 Changed 9 years ago by kini

  • Description modified (diff)

comment:9 Changed 9 years ago by kini

  • Resolution set to duplicate
  • Status changed from new to closed

Moving this to #748.

comment:10 Changed 9 years ago by kini

  • Milestone changed from sage-5.1 to sage-duplicate/invalid/wontfix
  • Resolution duplicate deleted
  • Status changed from closed to new

Going through Jeroen instead.

comment:11 Changed 9 years ago by kini

  • Status changed from new to needs_review

comment:12 Changed 9 years ago by kini

  • Status changed from needs_review to positive_review

comment:13 Changed 9 years ago by kini

  • Reviewers set to Keshav Kini

comment:14 Changed 9 years ago by jdemeyer

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from positive_review to closed

comment:15 Changed 7 years ago by leif

Sign of life of IML upstream, see http://trac.sagemath.org/ticket/14648#comment:51 ff.

Note: See TracTickets for help on using tickets.