Opened 7 years ago

Closed 5 years ago

#13021 closed enhancement (duplicate)

Upgrade eclib

Reported by: Snark Owned by: tbd
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: cremona Merged in:
Authors: Reviewers: Julien Puydt, Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

There are now several more recent upstream tarballs available here http://code.google.com/p/eclib/downloads/list.

Attachments (2)

eclib-20120703.spkg (780.7 KB) - added by Snark 7 years ago.
spkg for eclib version 2012-07-03
trac_13021.patch (2.7 KB) - added by Snark 7 years ago.
Patch to make sage compile (and doctests run) with the spkg of eclib version 2012-07-03

Download all attachments as: .zip

Change History (16)

Changed 7 years ago by Snark

spkg for eclib version 2012-07-03

Changed 7 years ago by Snark

Patch to make sage compile (and doctests run) with the spkg of eclib version 2012-07-03

comment:1 Changed 7 years ago by Snark

  • Status changed from new to needs_review

comment:2 Changed 7 years ago by jdemeyer

Please fill in your real name as Author.

comment:3 Changed 7 years ago by Snark

  • Authors set to Julien Puydt

comment:4 Changed 6 years ago by kcrisman

  • Cc cremona added
  • Status changed from needs_review to needs_info
gc04855:sage-5.9.rc0 $ ./sage -i
Currently installed packages:
atlas-3.8.4.p1
<snip>
ecl-12.12.1.p2
eclib-20120830
ecm-6.3.p8
elliptic_curves-0.7
<snip>
gc04855:sage-5.9.rc0 $ 

So... is this ticket obsolete? Or should we now upgrade to the 2013 (or beyond) version here?

Also, the site is now on github.

comment:5 Changed 6 years ago by cremona

I think this ticket is now obsolete having been leapfrogged by whichever one introduced eclib-20120830.

I had been planning to make a new eclib spkg after flint-2.3 was in Sage, though the current build system (as at github now (April 2013)) works with or without it, the part of the code which provides Sage's CremonaModularSymbols?() is rather faster with Flint.

comment:6 follow-up: Changed 6 years ago by kcrisman

So could this ticket be repurposed for that?

comment:7 in reply to: ↑ 6 ; follow-up: Changed 6 years ago by cremona

Replying to kcrisman:

So could this ticket be repurposed for that?

Unless you are afraid that we will run out of ticket numbers, I don't think tha would save a lot -- the attachments here need changing as well as the description. A new ticket with a forward reference here seems simpler to me.

comment:8 in reply to: ↑ 7 Changed 6 years ago by kcrisman

So could this ticket be repurposed for that?

Unless you are afraid that we will run out of ticket numbers, I don't think tha would save a lot -- the attachments here need changing as well as the description. A new ticket with a forward reference here seems simpler to me.

Feel free to provide that, then; otherwise we can just close this.

comment:9 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:10 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:11 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:12 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:13 Changed 5 years ago by jdemeyer

  • Authors Julien Puydt deleted
  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Reviewers set to Julien Puydt, Jeroen Demeyer
  • Status changed from needs_info to positive_review

Duplicate of various other eclib upgrade tickets...

comment:14 Changed 5 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.