Opened 9 years ago

Closed 9 years ago

#13002 closed defect (duplicate)

Fix Singular interrupt timeout

Reported by: jdemeyer Owned by: mvngu
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: doctest coverage Keywords: sd40.5
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

This has been causing lots of errors lately:

sage -t  --long -force_lib devel/sage/sage/interfaces/expect.py
**********************************************************************
File "/padic/scratch/jdemeyer/merger/sage-5.1.beta1/devel/sage-main/sage/interfaces/expect.py", line 832:
    sage: singular.interrupt(timeout=3)  # sometimes very slow (up to 60s on sage.math, 2012)
Expected:
    False
Got:
    True
**********************************************************************

When it succeeds, it often takes a very long time (I've even seen 1000s on sage.math).

Attachments (1)

13002_singular_interrupt.patch (1004 bytes) - added by jdemeyer 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by jdemeyer

comment:1 Changed 9 years ago by jdemeyer

  • Status changed from new to needs_review

comment:2 Changed 9 years ago by jdemeyer

  • Status changed from needs_review to needs_work

Still fails sometimes...

comment:3 Changed 9 years ago by jdemeyer

  • Description modified (diff)
  • Priority changed from critical to blocker
  • Summary changed from Increase Singular doctest timeout to Fix Singular interrupt timeout

comment:4 Changed 9 years ago by jdemeyer

  • Milestone changed from sage-5.1 to sage-duplicate/invalid/wontfix
  • Priority changed from blocker to major
  • Status changed from needs_work to positive_review

This is actually a duplicate of #10476.

comment:5 Changed 9 years ago by jdemeyer

  • Authors Jeroen Demeyer deleted
  • Resolution set to duplicate
  • Reviewers set to Jeroen Demeyer
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.