Opened 9 years ago

Closed 6 years ago

#12998 closed defect (duplicate)

experimental package chomp-20100213.p2.spkg fails test on x86_64-Linux

Reported by: mariah Owned by: tbd
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords: chomp
Cc: jhpalmieri Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by mariah)

The experimental package chomp-20100213.p2.spkg fails the following test when added to sage-5.0 on skynet/eno:

eno% ./sage -t  --long -force_lib "devel/sage/sage/geometry/fan.py"
sage -t --long -force_lib "devel/sage/sage/geometry/fan.py" 
**********************************************************************
File "/home/mariah/sage/sage-5.0-x86_64-Linux-core2-fc/devel/sage/sage/geometry/fan.py", line 2779:
    sage: fan.complex().homology()
Expected:
    {0: 0, 1: 0, 2: Z x Z, 3: 0}
Got:
    {2: Z x Z, 3: 0}
**********************************************************************
File "/home/mariah/sage/sage-5.0-x86_64-Linux-core2-fc/devel/sage/sage/geometry/fan.py", line 2783:
    sage: fan.complex().homology()
Expected:
    {0: 0, 1: 0, 2: Z, 3: 0}
Got:
    {2: Z, 3: 0}
**********************************************************************
1 items had failures:
   2 of  22 in __main__.example_46
***Test Failed*** 2 failures.
For whitespace errors, see the file /home/mariah/.sage//tmp/fan_14118.py
         [9.2 s]
 
----------------------------------------------------------------------
The following tests failed:


        sage -t --long -force_lib "devel/sage/sage/geometry/fan.py"

See also #11713.

Change History (11)

comment:1 Changed 9 years ago by mariah

  • Description modified (diff)

comment:2 Changed 9 years ago by jhpalmieri

  • Cc jhpalmieri added

comment:3 Changed 9 years ago by jhpalmieri

I think this is a duplicate of #12607.

comment:4 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:5 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:6 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:7 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:8 Changed 6 years ago by chapoton

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

this is indeed a duplicate of #12607

comment:9 Changed 6 years ago by chapoton

  • Status changed from needs_review to positive_review

comment:10 Changed 6 years ago by chapoton

  • Keywords chomp added

comment:11 Changed 6 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.