Opened 9 years ago

Closed 7 years ago

#12992 closed defect (duplicate)

pari should avoid usage of mp_set_memory_functions

Reported by: pcpa Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: interfaces Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: None of the above - read trac for reasoning. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

I reported the issue to upstream and proposed a patch, for details, see http://pari.math.u-bordeaux.fr/cgi-bin/bugreport.cgi?bug=1317

I suggested a patch to not call mp_set_memory_functions if it will be a noop (when not handling signals), and upstream suggests fixing it in sagemath side by saving and restoring pointers when calling pari_init_opts.

Sage simply removes the mp_set_memory_functions call in the pari spkg, but I believe my proposed solution is better, and I am doing it in my work to build a sagemath package using system wide packages.

Attachments (1)

sage-5.2-pari.patch (1.4 KB) - added by pcpa 9 years ago.
Sample patch file to follow upstream suggestion and not patch pari

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by pcpa

Sample patch file to follow upstream suggestion and not patch pari

comment:1 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:2 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:3 Changed 7 years ago by pbruin

  • Milestone changed from sage-6.2 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

I think this can be closed as a duplicate of #15774.

comment:4 Changed 7 years ago by jdemeyer

  • Reviewers set to Jeroen Demeyer
  • Status changed from needs_review to positive_review

Agreed.

comment:5 Changed 7 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.