Opened 9 years ago

Closed 9 years ago

#12984 closed enhancement (duplicate)

Possible future issues with ECL build with unicode enabled

Reported by: pcpa Owned by: was
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: interfaces Keywords:
Cc: Merged in:
Authors: Reviewers: Karl-Dieter Crisman, Paulo César Pereira de Andrade
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

ecl 12.2.1 has unicode support enabled by default, what creates two string types, t_base_string and t_string. The problem is that sage does not properly handle those, as described in https://sourceforge.net/tracker/?func=detail&aid=3526370&group_id=30035&atid=398053

I made a simple patch for sagemath in my work in progress package for fedora using system packages, but now was also hit by a gc upgrade that no longer exports symbols used by ecl, as describe in https://sourceforge.net/tracker/?func=detail&aid=3526174&group_id=30035&atid=398053

Duplicate of #12985.

Change History (5)

comment:1 Changed 9 years ago by pcpa

Weird, I had only clicked on preview, but actual report is #12985 where I added a proposed patch and removed the second paragraph about yet another problem.

comment:2 Changed 9 years ago by kcrisman

  • Reviewers set to Karl-Dieter Crisman, Paulo César Pereira de Andrade
  • Status changed from new to needs_review

This can thus be closed as a duplicate.

comment:3 Changed 9 years ago by kcrisman

  • Status changed from needs_review to positive_review

comment:4 Changed 9 years ago by jdemeyer

  • Milestone changed from sage-5.1 to sage-duplicate/invalid/wontfix

comment:5 Changed 9 years ago by jdemeyer

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.