Opened 7 years ago

Closed 7 years ago

#12971 closed enhancement (fixed)

Biggs-Smith graph

Reported by: ncohen Owned by: jason, ncohen, rlm
Priority: major Milestone: sage-5.1
Component: graph theory Keywords: sd40.5
Cc: wdj, kini Merged in: sage-5.1.beta4
Authors: Nathann Cohen Reviewers: Keshav Kini
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: #12942, #12945, #12952 Stopgaps:

Description

Transitive graph. Edge-transitive graph. I honestly did not think I would end up with such a nice drawing :-)

Nathann

Attachments (2)

trac_12971.patch (4.0 KB) - added by ncohen 7 years ago.
trac_12971.reviewer.patch (4.5 KB) - added by kini 7 years ago.
apply to $SAGE_ROOT/devel/sage

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by ncohen

  • Dependencies set to #12942, #12945, #12952
  • Status changed from new to needs_review

Changed 7 years ago by ncohen

comment:2 follow-up: Changed 7 years ago by kini

Great, a new graph! :) But this time I cannot review it immediately, as I am going to the airport soon to catch a flight across the Pacific to go to Bug Days 19... so I will be offline for two days or so. Sorry to make you wait!

comment:3 in reply to: ↑ 2 Changed 7 years ago by ncohen

Great, a new graph! :) But this time I cannot review it immediately, as I am going to the airport soon to catch a flight across the Pacific to go to Bug Days 19... so I will be offline for two days or so. Sorry to make you wait!

Oh, Nice !! I would like to be there too ! Well, have a nice flight ! ;-)

Nathann

comment:4 Changed 7 years ago by kini

OK!! Time to review! :) I've made a reviewer patch, which I will attach after I make this comment. Besides the usual reformatting, I also removed a comma from the exception message, and changed the name of the function from BiggsSmith() to BiggsSmithGraph(). I guess I don't have a strong opinion about which name is better, but if you use BiggsSmith() then we should change all the other graph names for consistency, and that is infeasible, so for now, let's just keep it as BiggsSmithGraph().

If you agree with my review patch, then we can change it to positive review. :)

Changed 7 years ago by kini

apply to $SAGE_ROOT/devel/sage

comment:5 Changed 7 years ago by kini

  • Keywords sd40.5 added
  • Reviewers set to Keshav Kini

patchbot: apply trac_12971.patch trac_12971.reviewer.patch

comment:6 Changed 7 years ago by ncohen

  • Status changed from needs_review to positive_review

+1 :-)

Nathann

comment:7 Changed 7 years ago by jdemeyer

  • Merged in set to sage-5.1.beta4
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.