Opened 10 years ago

Closed 10 years ago

#12898 closed defect (fixed)

Update top-level README.txt

Reported by: jdemeyer Owned by: mvngu
Priority: blocker Milestone: sage-5.0
Component: documentation Keywords:
Cc: drkirkby Merged in: sage-5.0.rc1
Authors: Jeroen Demeyer Reviewers: William Stein, Karl-Dieter Crisman, David Kirkby, Martin Raum
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The file $SAGE_ROOT/README.txt still says you need a fortran compiler, except on OSX, with no mention of the gcc package, or how one might use or disable it.

Attachments (1)

12898_readme.patch (8.2 KB) - added by jdemeyer 10 years ago.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 10 years ago by jdemeyer

  • Authors set to Jeroen Demeyer
  • Status changed from new to needs_review

This is a first attempt.

comment:2 follow-up: Changed 10 years ago by kcrisman

  • Status changed from needs_review to needs_work

This doesn't make sense.

Since includes a GCC (GNU Compiler Collection) package.  In order to 

Trivial to fix but I don't know exactly what wording you want here. Maybe just one sentence instead of two? Anyway, the first sentence has no verb.

comment:3 in reply to: ↑ 2 Changed 10 years ago by jdemeyer

Replying to kcrisman:

Anyway, the first sentence has no verb.

"includes" is a verb :-)

comment:4 Changed 10 years ago by jdemeyer

  • Status changed from needs_work to needs_review

comment:5 Changed 10 years ago by was

  • Status changed from needs_review to positive_review

It looks good to me.

comment:6 follow-up: Changed 10 years ago by kcrisman

Aah! I was in the process of submitting...

For reference:


Anyway, the first sentence has no verb.

"includes" is a verb :-)

Main verb, yes.

Questions/comments:

  • Some things I kind of get are true from previous tickets (3 GB, changing to --optional from -optional and so forth) but I don't actually know they are true; I guess I should just trust the author? ;-)
  • So Sage compiles with Sun compilers on Solaris now because we build and use GCC? I don't remember reading that but haven't been paying close attention to the thread, seems plausible.
  • I understand that the v flag for untarring is optional, but if you remove that flag, then you should probably tell the user how long they should expect to wait for Sage to untar. It takes a long time (I've done this with a student on a couple occasions and we weren't sure if the connection had timed out!), and I would expect that some of the spkgs inside Sage likewise take at least more than a couple minutes to untar - ?

But in general this looks good and applies properly etc. Positive review? I can't take responsibility for every one of the little changes, like the comment about Ubuntu 12.04, obviously, so I hesitate... but seems like it's ready and certainly helpful.

comment:7 Changed 10 years ago by kcrisman

  • Reviewers set to William Stein, Karl-Dieter Crisman

comment:8 in reply to: ↑ 6 ; follow-up: Changed 10 years ago by jdemeyer

Replying to kcrisman:

So Sage compiles with Sun compilers on Solaris now because we build and use GCC?

Exactly. It's even tested on the buildbot (on i386 OpenSolaris at least).

I understand that the v flag for untarring is optional, but if you remove that flag, then you should probably tell the user how long they should expect to wait for Sage to untar. It takes a long time (I've done this with a student on a couple occasions and we weren't sure if the connection had timed out!), and I would expect that some of the spkgs inside Sage likewise take at least more than a couple minutes to untar - ?

Fair enough, I added back that flag.

comment:9 in reply to: ↑ 8 Changed 10 years ago by kcrisman

I understand that the v flag for untarring is optional, but if you remove that flag, then you should probably tell the user how long they should expect to wait for Sage to untar. It takes a long time (I've done this with a student on a couple occasions and we weren't sure if the connection had timed out!), and I would expect that some of the spkgs inside Sage likewise take at least more than a couple minutes to untar - ?

Fair enough, I added back that flag.

Either that or a clarification without -v is fine, I just wasn't sure if there was some other reason to get rid of that flag (e.g., the verbosity for some with a lot of image files is VERY verbose). I assume the -xj and -jx switch is because the mandatory flag is supposed to come first? I know little of such things but that seems plausible.

Nice that we can build more places. I wonder if Sage would even build with other compilers, then... say, on Windows or some other Unices... but probably not, due to other issues like linkers etc.? (About which I also know nothing, but it's fun to speculate.)

comment:10 follow-up: Changed 10 years ago by drkirkby

Is is true that "Each spkg in $SAGE_ROOT/spkg/standard/ is a bzip'd tarball", as stated? I doubt the bzip2 package is. I think that is an uncompressed tarball. I'm not sure if there are any others either.

Also, I don't know why anyone puts -xfj or similar, when xfj will do. Tar is not defined by POSIX, so it's impossible to give an authoritative answer, but every tar program I have ever used, does not need the minus sign. The use of x (to extract), c (to create), t (to view), u (to update) or r (to replace) are not options. You must have one of them. Since they are not options, you don't need the minus sign. The j is an option, but GNU tar does not require the minus sign. So one might as well save a bit of wear on the keyboard, and not put the minus sign.

I thought GNU tar was supposed to be a requirement to build Sage. In which case, one might as well drop the j too, since GNU tar will work out for itself that the file is compressed or not. If it's compressed, it will silently uncompress it.

Dave

comment:11 in reply to: ↑ 10 Changed 10 years ago by jdemeyer

Replying to drkirkby:

Is is true that "Each spkg in $SAGE_ROOT/spkg/standard/ is a bzip'd tarball", as stated? I doubt the bzip2 package is. I think that is an uncompressed tarball. I'm not sure if there are any others either.

bzip2 is gzip-compressed, the other packages are all bzip2-compressed.

comment:12 Changed 10 years ago by jdemeyer

  • Status changed from positive_review to needs_work

David, I made some changes you suggested. Please review.

comment:13 Changed 10 years ago by jdemeyer

  • Reviewers changed from William Stein, Karl-Dieter Crisman to William Stein, Karl-Dieter Crisman, David Kirkby
  • Status changed from needs_work to needs_review

comment:14 Changed 10 years ago by dimpase

new version says : "recent and equal versions of gcc, g++ and gfortran."

It is not clear what "equal" means here...

comment:15 Changed 10 years ago by jdemeyer

Clarified:

If you don't want to install GCC, you need to have recent
versions of gcc, g++ and gfortran; moreover, the versions must be equal.

comment:16 Changed 10 years ago by mraum

I think the double space looks a bit too much like emacs, and I removed it. I also made the link to the environment variable page more visible, and I removed the dash in the second tar command, just to be a bit more consequent (the other was removed as well).

Apart from this the changes look good.

comment:17 Changed 10 years ago by jdemeyer

I made some further changes:

  • README.txt

    diff --git a/README.txt b/README.txt
    a b  
    6969
    70701. Make sure you have the dependencies and 3 GB of free disk space.
    7171
    72    Linux: GCC, make, m4, perl, ranlib, and tar.
     72   Linux: gcc, make, m4, perl, ranlib, and tar.
    7373   (install these using your package manager)
    7474   On recent Debian or Ubuntu systems (in particular Ubuntu 12.04
    7575   "Precise"), you need the dpkg-dev package.
    7676
    77    OS X: Xcode.  Make sure you have installed the most recent version
     77   OS X: Xcode. Make sure you have installed the most recent version
    7878   of Xcode. For pre-Lion versions of OS X, you can download Xcode
    7979   from http://developer.apple.com/downloads/. For OS X Lion, you can
    8080   install it using the App Store. With Xcode 4.3 or later, you need
     
    112112
    113113On Linux, if you get this error message:
    114114
    115     " restore segment prot after reloc: Permission denied "
     115    Error: cannot restore segment prot after reloc: Permission denied
    116116
    117117the problem is probably related to SELinux. See the following URL for
    118118further information:
    119119
    120     http://www.ittvis.com/services/techtip.asp?ttid=3092
     120    http://www.exelisvis.com/Support/HelpArticleDetail/ArticleId/3092.aspx
    121121
    122122
    123123IMPLEMENTATION
     
    184184       export SAGE_CHECK="yes"
    185185
    186186   before starting the Sage build. This will run each test suite and
    187    will raise an error if any failures occur.  Warning: on many
    188    platforms, this will cause failures in the installation of the
    189    Python spkg, so Python's test suite has been disabled by default.
    190    To renable it, set the environment variable SAGE_CHECK_PACKAGES to
    191    'python'.
    192 
     187   will raise an error if any failures occur. Python's test suite has
     188   been disabled by default, because it causes failures on most
     189   systems. To renable the Python testsuite, set the environment
     190   variable SAGE_CHECK_PACKAGES to "python".
     191
    193192   To start the build, type:
    194193
    195194       make
    196195
    197 
    1981964. Wait about 1 hour to 14 days, depending on your computer (it took
    199197   about 2 weeks to build Sage on the T-Mobile G1 Android cell phone).
    200198
     
    265263
    266264Sage includes a GCC (GNU Compiler Collection) package. In order to
    267265build Sage, you need a C compiler which can build GCC and its
    268 prerequisites. GCC version 4.0.1 or later should probably work. On
     266prerequisites. gcc version 4.0.1 or later should probably work. On
    269267Solaris or OpenSolaris, building with the Sun compiler should also work.
    270268
    271269The GCC package in Sage is not always installed. It is determined

Changed 10 years ago by jdemeyer

comment:18 Changed 10 years ago by mraum

  • Status changed from needs_review to positive_review

Looks good now.

comment:19 Changed 10 years ago by mraum

  • Reviewers changed from William Stein, Karl-Dieter Crisman, David Kirkby to William Stein, Karl-Dieter Crisman, David Kirkby, Martin Raum

comment:20 Changed 10 years ago by jdemeyer

  • Merged in set to sage-5.0.rc1
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.