Opened 9 years ago

Closed 8 years ago

#12856 closed enhancement (duplicate)

multiline doctests starting with '....:'

Reported by: dkrenn Owned by: mvngu
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: doctest coverage Keywords: multiline doctest
Cc: Merged in:
Authors: Reviewers: Daniel Krenn
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by dkrenn)

Since the Sage prompt for multiline commands is ....:, this should also work for doctests. At the moment you have to use the python ... prompt for doctests.

Apply attachment:trac_12856_multiline_doctests.patch to the scripts repo.

Attachments (1)

trac_12856_multiline_doctests.patch (1016 bytes) - added by dkrenn 9 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by dkrenn

comment:1 Changed 9 years ago by dkrenn

  • Authors set to Daniel Krenn
  • Description modified (diff)
  • Status changed from new to needs_review

comment:2 Changed 9 years ago by dkrenn

comment:3 Changed 9 years ago by kini

See also #10458 and #12415. (I suspect this and/or #10458 would need to be rebased on #12415 since the latter rewrites much of the doctest framework.)

comment:4 Changed 9 years ago by kini

Actually I guess this ticket is pretty much a duplicate of #10458...

comment:5 Changed 8 years ago by jdemeyer

  • Authors Daniel Krenn deleted
  • Milestone changed from sage-5.7 to sage-duplicate/invalid/wontfix
  • Reviewers set to Daniel Krenn
  • Status changed from needs_review to positive_review

comment:6 Changed 8 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.