Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1285 closed enhancement (duplicate)

[is duplicate of #1461] implement substitution of subexpression in calculus

Reported by: certik Owned by: mhansen
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: calculus Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

e.subs(x, y) needs to work, where "x" is an expression and "y" is an expression. and it substitutes x for y.

some tests from SymPy:

http://hg.sympy.org/sympy/file/d77f6c3b50bb/sympy/core/tests/test_subs.py

This is needed for the limit algorithm to work.

Change History (5)

comment:1 Changed 13 years ago by mhansen

  • Owner changed from was to mhansen
  • Status changed from new to assigned

comment:2 Changed 13 years ago by mabshoff

  • Milestone set to sage-2.9

comment:3 Changed 13 years ago by mhansen

  • Milestone changed from sage-2.10 to sage-2.9.1
  • Summary changed from implement substitution of subexpression in calculus to [is duplicate of #1461] implement substitution of subexpression in calculus

comment:4 Changed 13 years ago by rlm

  • Resolution set to duplicate
  • Status changed from assigned to closed

comment:5 Changed 13 years ago by mabshoff

  • Milestone changed from sage-2.9.1 to sage-duplicate/invalid
Note: See TracTickets for help on using tickets.